Default [Q] Disable permanently 4.4.2 update notification.

If You don't want to upgrade, and You like to disable the update notification popup, then:

Go into your Android settings.
Click on apps.
Swipe right to "all".
Click on Google services framework and uncheck "notifications".

Edit: Seems, this still doesn't help with Moto G, MotorolaOTA uncheck "notifications" should be the right one.