How to Root Android Wear 5.0.1 Lollipop Devices – XDA TV

The Lollipop update for Android Wear devices has hit the market and people are … more

Android 5.0.2 and New Factory Images For Nexus 7 (Wi-Fi) Available

Android 5.0 is has been publicly available since early November, and the … more

Github Tutorial App Shows You How to Use… Github

Github can get pretty complicated and using it can become quite daunting, especially … more

Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Wifi running super slow, please help. (Solved in my case)

OP shaolin95

11th January 2014, 03:16 AM   |  #31  
blueether's Avatar
Senior Member
Flag Te Awamutu, New Zealand
Thanks Meter: 1,523
 
3,191 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Quote:
Originally Posted by LordManhattan

Alright, so i guess i'm alone now. God damn it!

Congrats on "fixing" it though! $30 for a router is dirt cheap, so it's actually pretty funny to see that a cheap router does a better job than a $200 router. Just typical Well, i guess i'll have to take a closer look at my router tomorrow.

EDIT: Okay, so i just tested the up/down speed on both my laptop and my Ultra like 3 meters from the router.

- Laptop: 12Mbps down, 5Mbps up (as usual)
- Ultra: 12Mbps down (but then it fell down to 8Mbps) and 4Mbps up.

I then turned Wifi off and on again on the Ultra, and i got 12 down and 6 up. It works NOW, but my guess is that it'll start to drop in a few hours and i have no idea why.

Have you used something like a wifi analyzer to see who else is on the same channels?

Oh and check for cheap power supplies and fluro lights - they can spew out a lot of noise...
11th January 2014, 03:35 AM   |  #32  
Account currently disabled
Flag Kepler-34b
Thanks Meter: 5,664
 
15,002 posts
Join Date:Joined: Oct 2007
More
Quote:
Originally Posted by blueether

Have you used something like a wifi analyzer to see who else is on the same channels?

Oh and check for cheap power supplies and fluro lights - they can spew out a lot of noise...

Yup, there are like 10 2.4GHz networks around me, and 0 5GHz networks, but both 2.4 and 5 slows down after a couple of hours. I'm always getting max speeds on my laptop, and the Ultra is the only one that struggles. It will hit max and then slowly decrease down to almost half of that.

As mentioned earlier, it went back to normal after i turned the Wifi on my Ultra off and on for 3 seconds, so it has to be a software bug on my Ultra. I have the Netgear WNDR4300 which i got like two months ago.
16th January 2014, 01:41 AM   |  #33  
Senior Member
Thanks Meter: 84
 
310 posts
Join Date:Joined: Nov 2010
Just want to give a little update, wifi connection seems slows a lot, only at 3 Mbps. On iPad on the same connection speedtest shows normal fast speed.

1. Restarted modem and router, same result.
2. Turn off and turn on wifi on ZU, same result.
3. Forget wifi network, and reconnect, same result.
4. Almost give up with frustration.
5. Turn off phone and turn it back on, then finally the speed back to normal.

So at least on my phone, i think i need to restart my phone every other day to prevent the drop on wifi speed, but still need to see if it happens again in the next few days.
16th January 2014, 02:16 AM   |  #34  
Account currently disabled
Flag Kepler-34b
Thanks Meter: 5,664
 
15,002 posts
Join Date:Joined: Oct 2007
More
Quote:
Originally Posted by Vanquiz

Just want to give a little update, wifi connection seems slows a lot, only at 3 Mbps. On iPad on the same connection speedtest shows normal fast speed.

1. Restarted modem and router, same result.
2. Turn off and turn on wifi on ZU, same result.
3. Forget wifi network, and reconnect, same result.
4. Almost give up with frustration.
5. Turn off phone and turn it back on, then finally the speed back to normal.

So at least on my phone, i think i need to restart my phone every other day to prevent the drop on wifi speed, but still need to see if it happens again in the next few days.

I stumbled upon something today. Disable "WiFi optimization" (WiFi->Advanced). Some say it'll stop Android from "pinging" the router every couple of seconds. I disabled it a couple of hours ago, but my WiFi issue creeps up on me, so i'll have to wait and see if it solves my problem. Also, i read that disabling the "n" (in b/g/n) (local speed over 54Mbps) helps too. I haven't disabled that yet, but i still find it funny that my 4 year old laptop isn't having any issues with WiFi. I was on 4.4.2 (GPe ROM) earlier today and it was still the same, so it can't be software, and i refuse to believe that it's a hardware issue (since turning WiFi off and on speeds it up again), so it has to be my router or some crappy Android WiFi drivers.

I can of course set it to turn WiFi off when i turn the screen off, and that'll "refresh" the connection every time i use it, but then i'll have to wait a couple of seconds for it to connect every time i turn the screen on I ain't got time for dat!
The Following User Says Thank You to LordManhattan For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes