Post [Q] Galaxy S4 ME7 - No custom ROM will boot, tried everything I could find

Hi XDA,

For the past several days I've tried to Safestrap a custom ROM to my phone. I'm running a rooted Samsung Galaxy S4 with ME7 (Verizon), Android 4.2.2. It's worth noting that the phone has not received an official Verizon update since August; I tried using Loki back then before knowing about the locked bootloader, and it has not affected anything except that the phone softbricks into the ODIN screen whenever it tries to install a Verizon update. (I hope this is not the cause of the problem, but let me know if you think it is.) It's also worth noting that I deleted the stock messaging app (SecMMS.apk and SecMMS.odex.) I am using Safestrap 3.65.

So far, I've tried three different ROMs (Hyperdrive RLS10.2, Jelly Beans Build 7, Google Play Edition for 4.2.2.) Each install produced the same results: it installs just fine in the ROM slot (along with the ME7 modules afterwards), but when I reboot the system, it shows the Samsung logo, the Safestrap splash screen, and then the screen goes black indefinitely. A battery removal is required.

I've tried every trick I could find to get the ROMs working. I've done a full factory reset each time (data + both caches), tried downloading each mod several times on both my phone and my computer (verified MD5 each time) and same with the modules, waited at least 20 minutes during each boot attempt, tried installing each ROM with default settings and minimal apps, used Stock kernels each time, made sure the modules are installed before rebooting (I also tried without the modules to make sure they weren't the problem--same result.) Each time I try an install, I delete the ROM slot and format it again (usually a 1GB-2GB-300MB split.) I've searched and searched and can't seem to find anyone with this problem that hasn't solved it through one of the fixes I've unsuccessfully tried.

I'm plum out of ideas now, and am hoping someone may have more wisdom to share. Please help!