Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,804,955 Members 52,932 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Rooted Nexus 7 Unique MTP Issues

Tip us?
 
bkbkaufman
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jan 2014
Default [Q] Rooted Nexus 7 Unique MTP Issues

Ok so I have a rooted nexus 7 that won't show up as an mtp device ever since I rooted another nexus 7 on the same computer. I have uninstalled all the drivers and re installed them a million times with device manager and USBDview nothing works. It connects to other computers as an mtp device, however ever since I rooted the other nexus 7 on the same computer it won't work. Also I don't have access to the other nexus because it was my friends. Obviously it's a computer issue because it connects to other computers as an mtp. I'm really out of things to try as I have searched for this problem, but only found people saying to re install the drivers. I would really appreciate some help because I don't know what to do. Thanks.
 
airberger
Old
#2  
Junior Member
Thanks Meter 2
Posts: 3
Join Date: Nov 2013
Quote:
Originally Posted by bkbkaufman View Post
Ok so I have a rooted nexus 7 that won't show up as an mtp device ever since I rooted another nexus 7 on the same computer. I have uninstalled all the drivers and re installed them a million times with device manager and USBDview nothing works. It connects to other computers as an mtp device, however ever since I rooted the other nexus 7 on the same computer it won't work. Also I don't have access to the other nexus because it was my friends. Obviously it's a computer issue because it connects to other computers as an mtp. I'm really out of things to try as I have searched for this problem, but only found people saying to re install the drivers. I would really appreciate some help because I don't know what to do. Thanks.
I also have weird issues. What I usually do is make sure the Nexus is configured for only one connection. So for MTP mounting I have PTP unchecked and USB debugging unchecked. Then I plug into the computer.

If it doesn't mount as MTP, I find it's usually because Windows has attempted to connect via ADB drivers. So I go into Device Manager and uninstall the device under "Android" while checking the box to remove drivers for the device. Then I unplug the Nexus and plug it back in, and it uses MTP drivers. I've always struggle with these driver issues for the Nexus, i don't know why it's so difficult. Good luck!
 
datallboy
Old
#3  
datallboy's Avatar
Senior Member
Thanks Meter 88
Posts: 487
Join Date: Feb 2013
Location: Fremont, OH

 
DONATE TO ME
When I had issues with my mtp I had to uninstall adb drivers then plug my device back in so it would use mass storage and install the drivers. Somehow I have adb and mass storage working now with USB debugging on.

Check in device manager when you have adb uninstalled and see what your device comes up as.

Sent from my Nexus 7 using xda app-developers app
Current Devices

XDA Banner

Retired Devices

Nook Tablet 8GB

Email: datallboy@gmail.com
 
bkbkaufman
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jan 2014
Quote:
Originally Posted by datallboy View Post
When I had issues with my mtp I had to uninstall adb drivers then plug my device back in so it would use mass storage and install the drivers. Somehow I have adb and mass storage working now with USB debugging on.

Check in device manager when you have adb uninstalled and see what your device comes up as.

Sent from my Nexus 7 using xda app-developers app
I uninstall the adb drivers but for some reason windows automatically installs them right back instead of mtp drivers and then if I go to update drivers and select mtp as an option it says it won't work
 
bkbkaufman
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jan 2014
When I try to install the mtp drivers it says "Windows found driver software for your device but encountered an error while trying to install it...your device can't start" Then it automatically installs the adb drivers. What would be the reason it won't let me install the mtp usb drivers? Has anyone else encountered this?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes