5,603,729 Members 37,897 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Runtime reverting to Dalvik?

Tip us?
 
Sythun
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 4
Join Date: Sep 2012
Default [Q] Runtime reverting to Dalvik?

Every time I try to change runtime to ART and reboot, the option still says "Use Dalvik". There also isn't a long boot time and the 'Android is upgrading' wait.

I am able to change to ART runtime if I do a clean flash of Omnirom but unable to do so after installing all of my apps.

Is there a log to see which apps are causing this? or if it's app related at all?

I am using Samsung Galaxy S3 i9300. I have also flashed SuperSU and Temasek Kernel.
 
BeDesireS
Old
#2  
BeDesireS's Avatar
Senior Member
Thanks Meter 259
Posts: 828
Join Date: Aug 2011
Location: Trier
Quote:
Originally Posted by Sythun View Post
Every time I try to change runtime to ART and reboot, the option still says "Use Dalvik". There also isn't a long boot time and the 'Android is upgrading' wait.

I am able to change to ART runtime if I do a clean flash of Omnirom but unable to do so after installing all of my apps.

Is there a log to see which apps are causing this? or if it's app related at all?

I am using Samsung Galaxy S3 i9300. I have also flashed SuperSU and Temasek Kernel.
I guess you are using exposed, that causes the issue with ART.
The Following User Says Thank You to BeDesireS For This Useful Post: [ Click to Expand ]
 
Sythun
Old
(Last edited by Sythun; 10th December 2013 at 04:36 PM.) Reason: Adding some extra information for archiving
#3  
Junior Member - OP
Thanks Meter 1
Posts: 4
Join Date: Sep 2012
Quote:
Originally Posted by BeDesireS View Post
I guess you are using exposed, that causes the issue with ART.
Ahh I see. Thanks.

Edit: Yep that was the issue. Uninstalled Xposed framework modifications and it worked. And also ART runtime doesn't seem to like low available space and will start causing crashes of apps.
 
Mikegrmn
Old
#4  
Senior Member
Thanks Meter 33
Posts: 226
Join Date: Aug 2013
I guess I'm a little late to the topic, but I installed CM11 on my nook color and my razr HD. After reading this thread, I uninstalled xposed from both devices.
Every time I change from Dalvik to Art, the boot process takes long, apps getting modified, and once it's all done and I check developer options, it's telling me that it runs Dalvik.
Is there a way to pinpoint which apps could cause this?
Would it be sufficient to remove all apps and then install one app after the other to see if Art is still running, or would I have to reinstall Android or at least wipe all user data?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes