Default [Q] No Streaming media on 3G data

First of all hi XDA community,

i've alway my answer to my question using the "search" option but this time i didn't find anything about my problem. English is not my first language so i'm sorry if u didn't understand... i'll try rewrite another way.

Device spec:

-HTC ONE SPRINT bad esn/Imei
-Unlock bootloader
-rooted
-stock rom 4.3 deodexed benny's
-connection test via 5-10MGPS depending of my area (3G or HDPSA(3.5G))
- call and texto works great



I'm using it with TELUS/KOODO provider and when im browsing on 3G data everything goes great but when i'm trying using media app streaming it just won't load or give me an error such "connection to server lost" or "can't play the video" or "video cannot be played" when i'm on the WIFI everything going great for watching video or doing anything.

Things i've tryed:
-Go to advanced > RTSP Proxy Address (for stock Gingerbread it's advanced > RTSP/HTTP Setting > RTSP Proxy Port). Make this 0.0.0.0. Also make the HTTP PD Proxy Address 0.0.0.0. Also change the ports for both of these to 0. Back out and you should be good.
-Hard reset
-Back to original rom 4.3
-radio/baseband i've tryed the 4 available (connection/reception isn't better with older one the best one is the newer one for data and reception in canada/montreal)

Maybe i'm missing something i've try almost everything that it can visually cause problem with DATA 3g Streaming so maybe anybody got the answer ur gonna become a god for me.... so thx guys for reading this post and trying figuring whats the problem

Have a nice day btw!