Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,145 Members 41,900 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Lag problems

Tip us?
 
tadamhicks
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Jan 2014
Default [Q] Lag problems

N10 runnin stock Android 4.4.2 rooted and unlockex using Chainfire.

I love Shadowgun Deadzone. Played it before rooting...fine. played after....fine. It was fine for several days after rooting and then suddenly I started getting tons of lag. Can't figure why.

Speed tests indicate my network is fine. Playing on my phone I get no lag. Fps test gives me an avg of 57-58 fps, though I didnotice a random dropoff while it was running.

I've tried anti-aliasing, speeding up animations, forcing the gpu...still the problem persist. I don't have issues withanything else, the device isvery smooth otherwise.

Any ideas? Tests i could do?
 
tadamhicks
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Jan 2014
Quote:
Originally Posted by tadamhicks View Post
N10 runnin stock Android 4.4.2 rooted and unlockex using Chainfire.

I love Shadowgun Deadzone. Played it before rooting...fine. played after....fine. It was fine for several days after rooting and then suddenly I started getting tons of lag. Can't figure why.

Speed tests indicate my network is fine. Playing on my phone I get no lag. Fps test gives me an avg of 57-58 fps, though I didnotice a random dropoff while it was running.

I've tried anti-aliasing, speeding up animations, forcing the gpu...still the problem persist. I don't have issues withanything else, the device isvery smooth otherwise.

Any ideas? Tests i could do?
Deleted and re installed the app and it's all good now. Further proof why testing is absolutelynecessary. Can't believe i overlooked this common remedy.

But, can anyone tell me why this would work? Why would this alleviate graphic lag when even wiping the device's cache partition didn't help?
 
mrgnex
Old
#3  
mrgnex's Avatar
Senior Member
Thanks Meter 265
Posts: 935
Join Date: Jan 2013
Location: Vlaardingen
Quote:
Originally Posted by tadamhicks View Post
Deleted and re installed the app and it's all good now. Further proof why testing is absolutelynecessary. Can't believe i overlooked this common remedy.

But, can anyone tell me why this would work? Why would this alleviate graphic lag when even wiping the device's cache partition didn't help?
Im no developer or something but maybe a file was corrupted and every time the game needed to load that file it would lag because the file was corrupted? Im just guessing..

Sent from my Galaxy Nexus using XDA Premium HD app
SΛMSUNG/Google Galaxy Nexus
ROM: Vanir Nightly
Kernel: A.S.K.P. Patty Remix

SΛMSUNG/Google Nexus 10
ROM: Vanir Nightly
Kernel: Stock Vanir
 
tadamhicks
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Jan 2014
That wouldnhave been my general assumption, too. But if so corrupted how? What sorts of things would have caused it to corrupt at a certain point?

I'm trying to think of what sot of file corruption would cause graphic lag. I devlop some, but crrtainly nothing like a hardcore game. My basic understanding of php/sql for the web is a poor plztform for grasping what goes in a very complex rendering environment.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes