Should You Get Wear? Wearer’s Practical Observations

Wear is said to not offer enough for mass adoption, even though its been in … more

SlimRoms: Updates on the Horizon

SlimRoms’ website has been experiencing technical difficulties for the last month or so, but … more

Your Favorite Wireless Charger?

Wireless charging is becoming more and more common as many OEMs are now starting to include this feature … more

ASUS US Invites Developers at XDA to Special Event

ASUS has built a solid name over the years for their computer components, but in the … more
Post Reply Subscribe to Thread Email Thread

SecEmail.apk v4.0 on KK 4.4.2 on i9100

16th January 2014, 07:09 PM   |  #1  
OP Junior Member
Flag Malaga
Thanks Meter: 0
 
17 posts
Join Date:Joined: Oct 2010
More
Sorry if this is the wrong Forum

I'm currently running SlimKat 4.4.2 ROM on my trusty old S2 19100, my issue is i hate the standard email client that came with it (Email 4.4.2) and therefore have tried to change it for one from an early ROM (SIV Series 2.05) which is a JB ROM and ran Email 4.0 and Exchange 4.1

I have deleted both Email and Exchange apks from system\apps
rebooted
replaced with SecEmail and SecExchange apks extracted from the older ROM
updated permissions
rebooted
cleared data on both
even wiped data with TBackup
rebooted

Every time i get force close error messages

I have tried 3 variants of the files i want, clean extract from the original ROM zip file, copied from a backup of the older working ROM and Tbackup copy.

I used a copy of the files from this post;
http://forum.xda-developers.com/show...postcount=4007

and it all worked fine the only difference being it is Email 4.1.2 rather than Email 4.0 which i want.

What am i doing wrong, can i not have Email 4.0 which was running fine on JB 4.1.2 on KitKat 4.4.?

Any help would be gratefully received

Cheers

Pros
17th January 2014, 05:27 AM   |  #2  
JunDavis's Avatar
Senior Member
Flag Crestview
Thanks Meter: 136
 
554 posts
Join Date:Joined: Jun 2012
More
Apparently isn't compatible with your current version.

Sent from my LG-P920 using xda app-developers app
The Following User Says Thank You to JunDavis For This Useful Post: [ View ]
17th January 2014, 08:31 AM   |  #3  
OP Junior Member
Flag Malaga
Thanks Meter: 0
 
17 posts
Join Date:Joined: Oct 2010
More
Info Compatibility
Quote:
Originally Posted by JunDavis

Apparently isn't compatible with your current version.

Sent from my LG-P920 using xda app-developers app

Thanks for that , are you able to clarify not compatible with Kit Kat 4.4.? and or the SlimKat ROM ?
Last edited by Prospidnick; 17th January 2014 at 09:10 AM. Reason: Double posted
17th January 2014, 08:43 AM   |  #4  
OP Junior Member
Flag Malaga
Thanks Meter: 0
 
17 posts
Join Date:Joined: Oct 2010
More
Info Compatibility
Quote:
Originally Posted by JunDavis

Apparently isn't compatible with your current version.

Sent from my LG-P920 using xda app-developers app

Thanks for that , are you able to clarify it not being compatible with Kit Kat 4.4.? and or the SlimKat ROM ?
18th January 2014, 04:56 PM   |  #5  
JunDavis's Avatar
Senior Member
Flag Crestview
Thanks Meter: 136
 
554 posts
Join Date:Joined: Jun 2012
More
Quote:
Originally Posted by Prospidnick

Thanks for that , are you able to clarify it not being compatible with Kit Kat 4.4.? and or the SlimKat ROM ?

Perhaps 4.4 on your device. Are you using the ART runtime? This may cause issues with certain apps.
19th January 2014, 11:23 AM   |  #6  
OP Junior Member
Flag Malaga
Thanks Meter: 0
 
17 posts
Join Date:Joined: Oct 2010
More
ART for ART's sake
Quote:
Originally Posted by JunDavis

Perhaps 4.4 on your device. Are you using the ART runtime? This may cause issues with certain apps.

To be honest i'm not sure, it wouldn't be me that would change the runtime it would be the developers of the ROM, for sure it's using Dalvik, but i don't profess to be anything other than an enthusiastic user, not a developer.
19th January 2014, 11:53 AM   |  #7  
OP Junior Member
Flag Malaga
Thanks Meter: 0
 
17 posts
Join Date:Joined: Oct 2010
More
To ART or to Dalvik
Quote:
Originally Posted by JunDavis

Perhaps 4.4 on your device. Are you using the ART runtime? This may cause issues with certain apps.

I have double checked my current ROM and noticed that under developer options it shows the runtime as Dalvik, with the option to choose ART, as i know nothing about ART i am not prepared to just click and play. Therefore i will go off and read what i can about ART, i'm not sure after a couple of hours of reading i will be much the wiser , but i'll give it a go.

Cheers.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes