Default LG D605 + BT headset buttons debug/modify

I have got LG L9 II with Jelly Bean 4.1.2 with kernel 3.4.0 (no newer firmware from LG nor other unofficial ports).
I paired with it my Scala Rider G4 (by Cardo Systems) motorcycle bluetooth headset.

Pairing went OK, audio is transmitted by headset. But BT buttons do not work (almost) at all:
- initialize call, end call (Media Button?) - no reaction after one press,
- same button pressed twice - phone starts redialing last number (this is not default action of headset),
- volume up pressed once - no reaction,
- volume up long pressed - next song in player,
- volume down - no action.

With Nokias Symbian, or even Android 4.0.4, headset worked great.

I tried many apps like:
- Bluetooth Launcher,
- Tasker,
- Bluetooth Hedset Control
They simply did nothing.

So I thought, that maybe there are strange key mappings for that device. I tried KeyNumerTracker and ButtonRemapper from this forum (http://forum.xda-developers.com/showthread.php?t=850464) - no reaction, like I did not press any button.

What can I do? Can I somehow check, whether BT buttons are received by phone? And change that strange reaction for dbl-press, long press?