Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] No network data connection

OP DekkerP6

20th January 2014, 12:48 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: Jan 2014
Hello all,

I got my P6 for a few days and from time to time I had troubles to connect the data network (2G and 3G).
When I switch the data on, it connects to the network for 1/2 seconde and then it disconnects (the H+ symbol stays on though). Switching the data off and on again only repeats the problem.

Restarting the phone allowed me to finally have a stable connection so far but since this morning it doesn't work anymore. Removing the sim didn't help.

I'm on B125.

Anyone encountered this problem and managed to solve it?
Thanks!
Last edited by DekkerP6; 20th January 2014 at 12:55 PM.
20th January 2014, 03:06 PM   |  #2  
OP Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: Jan 2014
I may have solved the problem.

Use tweakker from the play store to get the exact apn details for your carrier (mine is Base Belgium) and put them in the apn settings.

Since that I can connect the data without any issue (except a new bug: switching to "2g only" make the connection bug again, except if the data is switch off before and switch back on after a dozen of seconds). It seems that it is more like a carrier problem but that creates bugs only with Huawei products (source: internet).

It seems that the P6 is a very capricious phone, I love it but I wouldn't recommend it to anyone which is not an engineer!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes