Post Reply

[Q] how do I restore Sony Xperia T (LT30p) device validity for original updates

OP jelledj

20th January 2014, 12:48 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jan 2014
Hi all,

I bought a Sony Xperia T (LT30p) to use with CM as it was listed as supported, however I had some bad experiences and decided to go back to an orignal firmware.

However I got troubles making Sony recoginze my device as an valid original devices and it gives errors when trying to update from Sony desktop software or after installing and getting an update from the installed ROM.

I had to unlock my device with fastboot and I have flashed the boot.img with one from CM. I don't have the oringal boot.img anymore!!

I'm now running build number 91.A.1.140 from some James Bond firmware for the LT30p.

I would love to go back to a state where I can update my phone with the orginal Sony update software.

Can somebody provide some very detailed instructions on how to get this working.

Thank you in advanced
20th January 2014, 04:53 PM   |  #2  
Senior Member
Thanks Meter: 91
 
274 posts
Join Date:Joined: Jan 2011
Afaik relocking your bootloader should do the trick. Check the All-in-One thread to be sure though

There you can also find an FTF for relocking the bootloader, though I think Flashtool can do it also now.

Sent from my LT30p using xda app-developers app
Last edited by Mad Marty; 20th January 2014 at 04:58 PM.
The Following User Says Thank You to Mad Marty For This Useful Post: [ View ]
20th January 2014, 05:42 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by Mad Marty

Afaik relocking your bootloader should do the trick. Check the All-in-One thread to be sure though

There you can also find an FTF for relocking the bootloader, though I think Flashtool can do it also now.

Sent from my LT30p using xda app-developers app

Well that works!! They could have gave me that hint on the #freexperia irc channel.... Thank fellow dutchman!

# ./FlashToolConsole --action=flash --file="firmwares/LT30_relock_bootloader.ftf"
Running as root.
JAVA_HOME not set. Using default value : ./x10flasher_lib/linjre64
20/023/2014 18:23:30 - INFO - <- This level is successfully initialized
20/023/2014 18:23:30 - INFO - Flashtool Version 0.9.13.0 built on 2013-06-04 22:50:00
20/023/2014 18:23:30 - INFO - Choosed /home/user/CM/flashtool/FlashTool/firmwares/LT30_relock_bootloader.ftf
20/023/2014 18:23:30 - INFO - Preparing files for flashing
20/023/2014 18:23:30 - INFO - Preparing files for flashing
20/023/2014 18:23:30 - INFO - Please connect your phone in flash mode
libusb_get_string_descriptor_ascii : Timeout
libusb_get_string_descriptor_ascii : I/O Errors
20/024/2014 18:24:06 - INFO - Opening device for R/W
20/024/2014 18:24:06 - INFO - Device ready for R/W.
20/024/2014 18:24:06 - INFO - Reading device information
[====> ] 8%
20/024/2014 18:24:06 - INFO - Phone ready for flashmode operations.
[=============================> ] 58%
20/024/2014 18:24:06 - INFO - Current device : LT30p - CB51225SHV - 1268-3194_R1I - 1262-6309_9.1.A.1.140 - GLOBAL-HSPA_9.1.A.1.140
[=================================> ] 66%
20/024/2014 18:24:06 - INFO - Start Flashing
20/024/2014 18:24:06 - INFO - Processing loader.sin
20/024/2014 18:24:06 - INFO - Checking header
[=====================================> ] 75%
20/024/2014 18:24:06 - INFO - Flashing data
[==================================================] 100%
20/024/2014 18:24:07 - INFO - Loader : S1_Root_7054 - Version : R5F001 / Boot version : R10A118 / Bootloader status : ROOTED
20/024/2014 18:24:07 - INFO - Disabling final data verification check
[===============================> ] 62%
20/024/2014 18:24:07 - INFO - Flashing preset.ta
20/024/2014 18:24:07 - INFO - Writing TA unit : [00, 00, 08, B2, 00, 00, 00, 02, 00, 00]
[=====================================> ] 75%
20/024/2014 18:24:07 - INFO - Ending flash session
[========================================> ] 81%
20/024/2014 18:24:07 - INFO - Flashing finished.
20/024/2014 18:24:07 - INFO - Please unplug and start your phone
20/024/2014 18:24:07 - INFO - For flashtool, Unknown Sources and Debugging must be checked in phone settings
20/024/2014 18:24:07 - INFO - Log written to /home/user/CM/flashtool/FlashTool/flashtool_2014-01-20_06-23-30.log
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia T, TL, TX, V Q&A, Help & Troubleshooting by ThreadRank