5,593,650 Members 39,369 Now Online
XDA Developers Android and Mobile Development Forum

[TESTERS] Apply Within

Tip us?
 
finniest
Old
#1  
finniest's Avatar
Member - OP
Thanks Meter 32
Posts: 64
Join Date: Oct 2013

 
DONATE TO ME
Info [TESTERS] Apply Within

I need a couple of testers for a Senseless (both meanings of the word) ROM that I'm putting together. It is nothing too special, but with your help it might be decent. It is not Android 4.0+, but merely Honeycomb.

I'll take the first two people to reply to this post. I'll get them a testable ROM in the near future and they can have at it.

Maybe we can breath some much needed life into this forgotten tablet!
 
swikster
Old
#2  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Dec 2010
Default WiFi Error

I have tested your ROM and I think it's very well done! I only have one problem however. After following the Aroma install (I selected to replace the kernel so WiFi would work) my WiFi reports an error and will not connect to anything. I tried reloading the ROM several times and still no joy. I don't see anyone else having an issue with this so I'm wondering what I missed. Any help or advice would be greatly appreciated. Your ROM was my first install from the stock OS that comes from HTC.

Thanks in advance

---------- Post added at 12:01 PM ---------- Previous post was at 11:36 AM ----------

Quote:
Originally Posted by swikster View Post
I have tested your ROM and I think it's very well done! I only have one problem however. After following the Aroma install (I selected to replace the kernel so WiFi would work) my WiFi reports an error and will not connect to anything. I tried reloading the ROM several times and still no joy. I don't see anyone else having an issue with this so I'm wondering what I missed. Any help or advice would be greatly appreciated. Your ROM was my first install from the stock OS that comes from HTC.

Thanks in advance
I forgot to mention that I also tried installing the DoomLord Kernel WiFi Module.zip to fix and it didn't help.
 
finniest
Old
(Last edited by finniest; 21st March 2014 at 04:24 AM.)
#3  
finniest's Avatar
Member - OP
Thanks Meter 32
Posts: 64
Join Date: Oct 2013

 
DONATE TO ME
In order for Hive to work you should have the kernel by @idanfima installed -- either via Hive installer or fastboot. Hive also requires the WiFi modules that it installs because only they pair with that kernel -- and not DoomKernel or stock kernel.

The installer asks you if you want to install the kernel and I've never heard of this failing. Are you sure that you selected this option? For 99% of people just pressing [Next] for every question in the installer is the best option.

After the install your Settings->About->Software information->More should look like the following:



I suggest that you install again and verify as per above. If the kernel did not flash then you'll be the first second to report this. I don't know why some users encounter problems, but there is a manual method to install the kernel (the hive_x.zip /boot.img file) which you can perform.

To manually install the kernel take the following link to a tutorial on How to flash a new boot.img via Fastboot.

 
swikster
Old
#4  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Dec 2010
Default Directions

I think you nailed the problem right on the head with the Kernel on my tablet being incorrect. My tablet reports:

Kernel Version
2.6.35.10-g01487c4
htc-kernel@u18000-build-144 #1
SMP PREEMPT Sat Dec 3 05:14:25 CST 2011

Baseband Version
1.04.5501.15v2_30.60.550I.10P

Build Number (same as yours)

I did exactly as you prescribed by basically hitting next for all of the options in Aroma and had the same result. I'm somewhat familiar with Fastboot so all I would need is the Kernel.img to flash and I should be good to go right? Maybe the modem.zip also since they have to be mated and it may be that this file isn't flashing as well?

Thanks for your help with this

Chad
 
finniest
Old
#5  
finniest's Avatar
Member - OP
Thanks Meter 32
Posts: 64
Join Date: Oct 2013

 
DONATE TO ME
Quote:
Originally Posted by swikster View Post
Baseband Version
1.04.5501.15v2_30.60.550I.10P
That baseband differs from the one that is that same on both of my tablets, but I don't know if that is related.

Quote:
Originally Posted by swikster View Post
I did exactly as you prescribed by basically hitting next for all of the options in Aroma and had the same result.
You are the first to report this, so I'll have to look into why. Both of my tablets are from Rogers. Is yours from AT&T? For now we'll have to rely to fastboot to address your problem.

Quote:
Originally Posted by swikster View Post
I'm somewhat familiar with Fastboot so all I would need is the Kernel.img to flash and I should be good to go right? Maybe the modem.zip also since they have to be mated and it may be that this file isn't flashing as well?
You will just need the boot.img that is in the / directory of the Hive archive (hive_x.zip). Once you boot the tablet to Fastboot then you just need to fastboot flash boot boot.img.

I don't think you'll have to do anything with the radio since I've never heard of a radio image for the Jetstream before.


Let me know how it goes.
 
swikster
Old
#6  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Dec 2010
Default Kernel Issue Fixed

Just wanted to send an update. Your hunch about the Kernel being the problem was spot on. For some reason the Kernel wasn't flashing with the use of Aroma but when I went into ADB it flashed just fine and now WiFi works!

I do have an AT&T Jetstream. I'm not sure why that would be the cause but maybe you're onto something about the baseband being different that may be the cause. Either way I'm up and running now!

Thank you SO SO MUCH for the help with this! Although there aren't many of us left with a Jetstream I share your thoughts about the tablet still having a good value. I hope that someone will be able to help us up the OS to Jellybean or KK someday.

Take Care!

Chad
 
finniest
Old
#7  
finniest's Avatar
Member - OP
Thanks Meter 32
Posts: 64
Join Date: Oct 2013

 
DONATE TO ME
You can also try Hive II beta -- since it has an updated installer. I doubt that it fixes your kernel flashing issues, but it is possible. I wasn't going to release a beta, but with your situation it makes sense.

Even though you have solved the kernel problem you may still want to try this.

Download:

ROM: j.mp/hive_ii-beta
MD5 (optional): j.mp/hive_ii-beta-md5

The above links will redirect you to where the ROM is currently hosted.

The Following 2 Users Say Thank You to finniest For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Windows Phone 8.1 Developer Preview Now Available!

About two weeks ago at the BUILD conference in San Francisco, Microsoft unveiled Windows … more

Prevent Unwanted Butt Dialing with Smart Pocket Guard

You may recall that back in August of last year, we took a look atAir SwiperbyXDA … more

Google ATAP Details Project Ara in Developers’ Conference

Earlier today, the Google ATAP teamkicked offits first ever Project Ara … more