Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,780,028 Members 37,981 Now Online
XDA Developers Android and Mobile Development Forum

New phone doesn't turn on

Tip us?
 
qqisa
Old
(Last edited by qqisa; 21st January 2014 at 09:47 PM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 25
Join Date: Sep 2012
Location: Lima
Default New phone doesn't turn on

Hi
I bought my relay from ebay http://goo.gl/GbQ1Nt just started using the phone today.. I put my SIM card of a carrier from Peru and it worked just fine. Everything was running smoothly.. I was making phonecalls and texting.. I put my gmail account and started downloadign some apps..
After a couple of hours, the battery was almost dead so I plugged it..
After five minutes, the screen turned off out of the blue.. and I haven't been able to turn it on since
It won't turn on, nor enter recovery or download mode
I'm not even sure it is charging.. when i plug it the red led turns on.. but there is no other charging indicator..

I'm in Peru so returning it is a bit o f a challenge.. I was just wondering if any of you guys know what could be wrong..

Thanks
 
jgummeson
Old
#2  
Junior Member
Thanks Meter 3
Posts: 24
Join Date: Dec 2011
Location: Hadley, MA
Quote:
Originally Posted by qqisa View Post
Hi
I bought my relay from ebay (http://goo.gl/7v8j1Z)I just started using the phone today.. I put my SIM card of a carrier from Peru and it worked just fine. Everything was running smoothly.. I was making phonecalls and texting.. I put my gmail account and started downloadign some apps..
After a couple of hours, the battery was almost dead so I plugged it..
After five minutes, the screen turned off out of the blue.. and I haven't been able to turn it on since
It won't turn on, nor enter recovery or download mode
I'm not even sure it is charging.. when i plug it the red led turns on.. but there is no other charging indicator..

I'm in Peru so returning it is a bit o f a challenge.. I was just wondering if any of you guys know what could be wrong..

Thanks
The link you posted for the auction doesn't work. Wanted to check if you got it new or used. One thing I've noticed with mine is that I have to hold down the power button for a second or two to get it to turn on (seemed like it was a little bit longer than other phones I've had).

Outside of that it sounds like it might be some kind of hardware problem. Might even just be a bad battery. One thing you could try is using an external charger for the battery if you have a universal lithium ion charger or if you know someone who has one. That way you might be able to narrow it down to a problem with the charging circuit in the phone.
 
qqisa
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 25
Join Date: Sep 2012
Location: Lima
Quote:
Originally Posted by jgummeson View Post
The link you posted for the auction doesn't work. Wanted to check if you got it new or used. One thing I've noticed with mine is that I have to hold down the power button for a second or two to get it to turn on (seemed like it was a little bit longer than other phones I've had).

Outside of that it sounds like it might be some kind of hardware problem. Might even just be a bad battery. One thing you could try is using an external charger for the battery if you have a universal lithium ion charger or if you know someone who has one. That way you might be able to narrow it down to a problem with the charging circuit in the phone.
thanks for replying
I've edited the link

I tried an external power bank but it didn't even turn it on.. so I narrowed it like you said to: the battery is so messed up it won't even charge or the battery is fine but the whole charging circuit is wrong.

Then I took it to an electrician and he said the battery had energy and should start the phone, but it didn't.
After that he charged the battery alone for a little bit with his "whatever kind of car-battery-like thing" but it still was not turning the phone on.

When I came home I plugged it once more to the external powerbank and some how the charging animation appeared..
I let it charge for a while but it didn't seem to progress, so i turned it on and holly crap it turned on

but after the boot animation it vibrated and turned off and now it's not charging again
man.. i thought i had it
any thoughts?

i've read about something called sticky power button.. its a hardware problem in the galaxy sII model.. could it be related?
 
jgummeson
Old
#4  
Junior Member
Thanks Meter 3
Posts: 24
Join Date: Dec 2011
Location: Hadley, MA
Not sure about the sticky power button I've never had it happen to me. I would think that when you had it on it would have popped up the reboot menu like when the power button is being held down. If it were me I would contact the seller.
 
qqisa
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 25
Join Date: Sep 2012
Location: Lima
i returned to the electrician and he recharged a little bit more the battery..
this time it did turned on and it reached the lockscreen it said 1%
so I plugged it.. and it now stays on.. and it says charging but stays at 0%.. doesn't advance.. is it a battery issue or a charging circuit issue?
forget about the sticky power button
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes