FORUMS

Analysis & Opinion

[Q] Gapps issue - location and play services keep force closing

81 posts
Thanks Meter: 12
 
By Will Rickards, Member on 21st January 2014, 03:48 AM
Post Reply Subscribe to Thread Email Thread
I flashed the codefirex ROM with android 4.3 to my ltevo.
It worked fine at first but when the google play updates started to install it began force closing the play service and location service stuff.
Dialogs would appear and I'd click ok and it would come up again. Made the phone unusable really. Difficult to even reboot.

Anybody else experience this? I flashed the gapps from 20130813 jellybean.
They seemed to work fine until they updated.
 
 
21st January 2014, 01:08 PM |#2  
AarSyl's Avatar
Senior Member
Flag NJ
Thanks Meter: 812
 
More
Did you dirty flash? Maybe you should try reflashing Gapps to see what happens.

_______________________________________
Phone: HTC EVO 4G LTE
Sense 5, S-Off

Tablet: ASUS Nexus 7.2
Rooted, Custom Rom & Kernel
22nd January 2014, 06:50 AM |#3  
wolfclan68's Avatar
Senior Member
Flag Chula Vista, Ca
Thanks Meter: 89
 
More
Quote:
Originally Posted by Will Rickards

I flashed the codefirex ROM with android 4.3 to my ltevo.
It worked fine at first but when the google play updates started to install it began force closing the play service and location service stuff.
Dialogs would appear and I'd click ok and it would come up again. Made the phone unusable really. Difficult to even reboot.

Anybody else experience this? I flashed the gapps from 20130813 jellybean.
They seemed to work fine until they updated.

Try these, they've been good to me on 4.3 and 4.4 there are separate versions for each: http://forum.xda-developers.com/show....php?t=2397942
The Following User Says Thank You to wolfclan68 For This Useful Post: [ View ]
22nd January 2014, 02:57 PM |#4  
OP Member
Thanks Meter: 12
 
More
This is the process I followed. I repeated it last night just to be sure.
Recovery is TWRP 2.6.3.0. The one for CM11 kitkat.
1. I went into wipe and advanced wipe and selected Dalvik Cache, Cache, Data, System, Android Secure.
2. I went into install and selected the ROM zip and installed.
3. I went into install and selected the gapps zip and installed.
4. I went into install and selected the supersu zip and installed.
5. I wiped Dalvik Cache and cache.
6. Reboot.

It then works fine till google play services auto updates.
Then I get closes in gsf.login, location and play services.
If I revert google play services it works again.
22nd January 2014, 03:04 PM |#5  
OP Member
Thanks Meter: 12
 
More
Thanks wolfclan68, I'll try those gapps later today.
Right now I'm setting up CM11 deck's build 2014-01-17.
22nd January 2014, 05:46 PM |#6  
Senior Member
Thanks Meter: 231
 
More
Have you tried unplugging it and plugging it back in?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes