Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,734,168 Members 51,339 Now Online
XDA Developers Android and Mobile Development Forum

Media controller not working right with S3

Tip us?
 
djmvt
Old
#1  
djmvt's Avatar
Member - OP
Thanks Meter 17
Posts: 94
Join Date: Aug 2005
Location: Rosmalen

 
DONATE TO ME
Default Media controller not working right with S3

Searching for the same problem with other gear owners but can't seem to find it:

When I use the media controller on the gear I can only change volume up/down but no track skip or play/pause.
Tried this with stock player and also spotify.

Both my phone and the gear are full stock unrooted devices, phone running on android 4.3 MK6, gear on na6.

Smart switching isn't working either.

Any tips what to do? Tried null already, no difference.


Sent from my Nexus 10 using XDA Premium HD app
Galaxy S4 running latest stock TW FW (android 4.3)
Nexus10 stock rooted KitKat (android 4.4.2)
 
horizons1
Old
#2  
Member
Thanks Meter 6
Posts: 37
Join Date: Nov 2007
It's fickle at best. Sometimes I hit Play and nothing happens, other times it works and always starts playing the stock audio player.

Have you tried starting media on the phone first and then attempting to change tracks or pause on the Gear? I have been more successful that way and usually use it when flying (as I am right now) to control Google Play Music or the stock video player on my S3.

Another observation - sometimes when I use the media controller, the album art shows up, other times it doesn't. For the same track. Sometimes the title and artist show up for a few secs, sometimes it goes straight to the five buttons.

As I said - fickle


Running Null19 and S3
The Following User Says Thank You to horizons1 For This Useful Post: [ Click to Expand ]
 
Brendo
Old
#3  
Brendo's Avatar
Senior Member
Thanks Meter 507
Posts: 2,326
Join Date: Oct 2006
Location: Brisbane, Australia

 
DONATE TO ME
Hmmm...never had any problems on my s4 - works perfect (controls and album art). Using stock music player as I assumed that is all that worked
Samsung Galaxy S IV (i9505) | 16GB
[ROM: Stock KK 4.4.2 | XXUFNC9 | MODEM GSM/LTE: XXUEML4/XXUFMC9 | BL: PRE-KNOX | K: ADAM | RECOVERY: PhilZ]
DOMINATION | XPOSED

OTHER DEVICES:
 
Google Nexus 5 | 32GB
Samsung Galaxy Tab 8.9 (P7310) | 32Gb
[ROM: CM10.2 | CPU: 1.4ghz]
Samsung Galaxy TabPro 10.1 LTE (T525) | 16Gb

Pebble (Kickstarter)
Galaxy Gear (Null_)
Gear Live ()
Google Glass (Explorer)

--------
My Android Downloads
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes