Post Reply

[Q] [CM 10.2] Why does this version allow me to mount USB with phone locked?

OP QQNoob

22nd January 2014, 09:02 PM   |  #1  
OP Member
Thanks Meter: 27
 
84 posts
Join Date:Joined: Jul 2012
Seems like a security flaw. Anyone can pick up my phone, plug it into a USB port and copy files within seconds. Normally, you'd have to at least have to reboot into recovery, which requires a forced reboot and knowing the proper keys to do that and to enter recovery. As it stands now, even a child could plug in my phone and access the entire SD card.

It's also annoying that if I plug in the phone to my PC to charge while I'm listening to music on it, I don't get the lock screen where I have music controls. I instead get the USB mounting screen. I just have to press the Home key to show the lock screen, but it's been bugging me.

Is there any way to disable this? It wasn't this way in CM 10.1.
Last edited by QQNoob; 22nd January 2014 at 09:05 PM.
23rd January 2014, 12:15 AM   |  #2  
timmaaa's Avatar
Recognized Contributor
Flag Melbourne
Thanks Meter: 6,808
 
14,120 posts
Join Date:Joined: Jun 2011
Donate to Me
More
Go back to an earlier version of Android, or don't lose your phone.

Sent from my Evita
23rd January 2014, 12:22 AM   |  #3  
OP Member
Thanks Meter: 27
 
84 posts
Join Date:Joined: Jul 2012
Quote:
Originally Posted by timmaaa

Go back to an earlier version of Android, or don't lose your phone.

Your useless answer is unappreciated. I asked two simple questions and you answered neither.
23rd January 2014, 12:37 AM   |  #4  
timmaaa's Avatar
Recognized Contributor
Flag Melbourne
Thanks Meter: 6,808
 
14,120 posts
Join Date:Joined: Jun 2011
Donate to Me
More
The fact is you can't disable it. The answers I gave are perfectly valid if you don't want want the ability to mount the sd card via the lockscreen. If you're allowing your phone to get into a position where someone can access it like that then what I'm saying is maybe you need to reassess the level of personal security in regards to the device.

Sent from my Evita
Last edited by timmaaa; 23rd January 2014 at 12:39 AM.
23rd January 2014, 12:38 AM   |  #5  
OP Member
Thanks Meter: 27
 
84 posts
Join Date:Joined: Jul 2012
>The fact is you can't disable it.

Now that is an appropriate answer. Thank you.

The main topic question was "why?" Why this change in behavior? What's the philosophy behind it?
23rd January 2014, 12:40 AM   |  #6  
timmaaa's Avatar
Recognized Contributor
Flag Melbourne
Thanks Meter: 6,808
 
14,120 posts
Join Date:Joined: Jun 2011
Donate to Me
More
I'm sorry but I don't know why they changed it like that.

Sent from my Evita
23rd January 2014, 12:49 AM   |  #7  
OP Member
Thanks Meter: 27
 
84 posts
Join Date:Joined: Jul 2012
I remember CM9 behaving like this in certain versions, but then it went away, and I never had it in any CM10 versions until now. It's like the developers can't decide how they want it, or it's some sort of mistake or bug.
23rd January 2014, 01:03 AM   |  #8  
timmaaa's Avatar
Recognized Contributor
Flag Melbourne
Thanks Meter: 6,808
 
14,120 posts
Join Date:Joined: Jun 2011
Donate to Me
More
It isn't the fault of developers here, I believe you can thank Google for that feature.

Sent from my Evita
23rd January 2014, 01:37 AM   |  #9  
pandasa123's Avatar
Senior Member
Flag South Grafton
Thanks Meter: 1,180
 
1,485 posts
Join Date:Joined: Jul 2013
Donate to Me
More
If you want it to not be like that, go and decompile some file and change the permissions.

Speaking of Google, I'm excited for the new Selinux policy from the NSA researcher. It'll be fun to see ChainFire at it

Sent from my One Xl using Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in One X Q&A, Help & Troubleshooting by ThreadRank