Question [SOLVED] Nearly gained S-OFF, gave up, stuck on FroYo. Can't RUU.

I recently acquired a used Incredible, and I followed the directions on this thread, with the goal of installing CM afterwards. I reached the last step (flashing the unrevoked forever patch), but it failed with a status 6.

After some searching, I decided to just go back to the drawing board and tried to OTA to Gingerbread again. That didn't work, so I tried the RUUs on pvillecomp.com - still no dice. Trying to flash a stock ROM from the same site (and doing steps 34-38 from the aforementioned thread) also fails.

So now I'm completely stuck and just want to return to stock GB. Any ideas?

IncredibleC XD Ship S-ON
Hboot 1.07.0000
MicroP-0417
Radio 2.15.00.07.20

EDIT: It turns out that this thread has a link to a different version of the unrEVOked forever patch. I reflashed the CWM recovery, then flashed the patch and it worked fine. So I now have S-OFF - and CM7 installed.
Active Devices:
Motorola Droid Razr M (stock 4.1.2, locked BL but rooted)
Acer Iconia Tab A200 (Omnirom 4.2.2 unofficial)

Alternates:
Motorola Droid X2 (stock 2.3.6, rooted)
HTC Droid Incredible (Cyanogenmod 7.2)