FORUMS

XPrivacy for Android Lollipop – XDA Xposed Tuesday

Have you ever been on the Google Play Store and saw an app that you wanted to … more

How a HTC Droid Eris Changed a Members Life

Rarely can a member say that Android development or XDA had a profound effect on … more

XDA Office Space: Frankenstein’s Perfect IM Client?

The portal’s decentralized XDA office lies in a Hangouts chatroom, where … more

Which IM Client on Android is best?

With so many different messengers to choose from, it can be tough to find the best one for you and … more
Post Reply Subscribe to Thread Email Thread

Omni Rom for I9500 build error

22nd January 2014, 09:27 PM |#1  
BlaqueDroid's Avatar
OP Senior Member
Flag Johannesburg
Thanks Meter: 1,070
 
Donate to Me
More
Hey Guys Im trying to compile for I9500 and here is the error im getting below and im using this device tree
https://github.com/intervigilium/and..._samsung_i9500


build/core/product_config.mk:222: *** Can not locate config makefile for product "omni_i9500". Stop.
WARNING: Trying to fetch a device that's already there
build/core/product_config.mk:222: *** Can not locate config makefile for product "omni_i9500". Stop.

** Don't have a product spec for: 'omni_i9500'
** Do you have the right repo manifest?

Please help guys what am i doing wrong
 
 
22nd January 2014, 10:25 PM |#2  
Senior Member
Flag Arnhem
Thanks Meter: 1,974
 
Donate to Me
More
Quote:
Originally Posted by BlaqueDroid

Hey Guys Im trying to compile for I9500 and here is the error im getting below and im using this device tree
https://github.com/intervigilium/and..._samsung_i9500


build/core/product_config.mk:222: *** Can not locate config makefile for product "omni_i9500". Stop.
WARNING: Trying to fetch a device that's already there
build/core/product_config.mk:222: *** Can not locate config makefile for product "omni_i9500". Stop.

** Don't have a product spec for: 'omni_i9500'
** Do you have the right repo manifest?

Please help guys what am i doing wrong

If you are using that device tree without any modifications, it will not work for Omni. The device tree is for cm. Have a look at some of the Omni device trees. At least you need to alter the vendorsetup.sh and the make files.

Verstuurd vanaf mijn TF300T met Tapatalk
23rd January 2014, 02:59 AM |#3  
BlaqueDroid's Avatar
OP Senior Member
Flag Johannesburg
Thanks Meter: 1,070
 
Donate to Me
More
Quote:
Originally Posted by scanno

If you are using that device tree without any modifications, it will not work for Omni. The device tree is for cm. Have a look at some of the Omni device trees. At least you need to alter the vendorsetup.sh and the make files.

Verstuurd vanaf mijn TF300T met Tapatalk

Hey man i tried following the instructions on the omni wiki site but still it kept on saying the same error an i would appreciate it if u can point me in the right direction ...e.g what files to modify ?
23rd January 2014, 09:06 AM |#4  
Senior Member
Flag Arnhem
Thanks Meter: 1,974
 
Donate to Me
More
Quote:
Originally Posted by BlaqueDroid

Hey man i tried following the instructions on the omni wiki site but still it kept on saying the same error an i would appreciate it if u can point me in the right direction ...e.g what files to modify ?

First you have to "omnify" the device tree. That means renaming and editing the make files in the device tree. Please have a look at the other device trees and look at the make file changes to files like vendorsetup.sh. Also you should have an omni_<device>.mk . Again look what has been done with other devices to make them build it the Omni tree.


Verstuurd vanaf mijn Nexus 10 met Tapatalk
23rd January 2014, 10:13 AM |#5  
Senior Member
Thanks Meter: 2,075
 
More
Also, it'd help if you uploaded your changes/device tree to github. That way we can see what you're doing and help better. Like was already said, the tree as is won't work.
23rd January 2014, 07:30 PM |#6  
BlaqueDroid's Avatar
OP Senior Member
Flag Johannesburg
Thanks Meter: 1,070
 
Donate to Me
More
Quote:
Originally Posted by PonsAsinorem

Also, it'd help if you uploaded your changes/device tree to github. That way we can see what you're doing and help better. Like was already said, the tree as is won't work.

Hey MAn thanks for the advice i managed to fix the device tree issue but now im stuck with this error ....any ideas

Code:
Copy xml: /home/blaquesoul/android/omni/out/target/product/i9500/system/etc/permissions/android.software.sip.voip.xml
make: *** No rule to make target `/configs/audio_effects.conf', needed by `/home/blaquesoul/android/omni/out/target/product/i9500/system/etc/audio_effects.conf'.  Stop.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Omni Q&A by ThreadRank