Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,283 Members 38,754 Now Online
XDA Developers Android and Mobile Development Forum

Omni Rom for I9500 build error

Tip us?
 
BlaqueDroid
Old
#1  
BlaqueDroid's Avatar
Senior Member - OP
Thanks Meter 418
Posts: 218
Join Date: Oct 2013
Location: Johannesburg

 
DONATE TO ME
Default Omni Rom for I9500 build error

Hey Guys Im trying to compile for I9500 and here is the error im getting below and im using this device tree
https://github.com/intervigilium/and..._samsung_i9500


build/core/product_config.mk:222: *** Can not locate config makefile for product "omni_i9500". Stop.
WARNING: Trying to fetch a device that's already there
build/core/product_config.mk:222: *** Can not locate config makefile for product "omni_i9500". Stop.

** Don't have a product spec for: 'omni_i9500'
** Do you have the right repo manifest?

Please help guys what am i doing wrong
 
scanno
Old
#2  
Senior Member
Thanks Meter 1,482
Posts: 1,047
Join Date: Mar 2008
Location: Arnhem

 
DONATE TO ME
Quote:
Originally Posted by BlaqueDroid View Post
Hey Guys Im trying to compile for I9500 and here is the error im getting below and im using this device tree
https://github.com/intervigilium/and..._samsung_i9500


build/core/product_config.mk:222: *** Can not locate config makefile for product "omni_i9500". Stop.
WARNING: Trying to fetch a device that's already there
build/core/product_config.mk:222: *** Can not locate config makefile for product "omni_i9500". Stop.

** Don't have a product spec for: 'omni_i9500'
** Do you have the right repo manifest?

Please help guys what am i doing wrong
If you are using that device tree without any modifications, it will not work for Omni. The device tree is for cm. Have a look at some of the Omni device trees. At least you need to alter the vendorsetup.sh and the make files.

Verstuurd vanaf mijn TF300T met Tapatalk
 
BlaqueDroid
Old
#3  
BlaqueDroid's Avatar
Senior Member - OP
Thanks Meter 418
Posts: 218
Join Date: Oct 2013
Location: Johannesburg

 
DONATE TO ME
Quote:
Originally Posted by scanno View Post
If you are using that device tree without any modifications, it will not work for Omni. The device tree is for cm. Have a look at some of the Omni device trees. At least you need to alter the vendorsetup.sh and the make files.

Verstuurd vanaf mijn TF300T met Tapatalk
Hey man i tried following the instructions on the omni wiki site but still it kept on saying the same error an i would appreciate it if u can point me in the right direction ...e.g what files to modify ?
 
scanno
Old
#4  
Senior Member
Thanks Meter 1,482
Posts: 1,047
Join Date: Mar 2008
Location: Arnhem

 
DONATE TO ME
Quote:
Originally Posted by BlaqueDroid View Post
Hey man i tried following the instructions on the omni wiki site but still it kept on saying the same error an i would appreciate it if u can point me in the right direction ...e.g what files to modify ?
First you have to "omnify" the device tree. That means renaming and editing the make files in the device tree. Please have a look at the other device trees and look at the make file changes to files like vendorsetup.sh. Also you should have an omni_<device>.mk . Again look what has been done with other devices to make them build it the Omni tree.


Verstuurd vanaf mijn Nexus 10 met Tapatalk
 
PonsAsinorem
Old
#5  
Senior Member
Thanks Meter 2,070
Posts: 3,974
Join Date: Sep 2010

 
DONATE TO ME
Also, it'd help if you uploaded your changes/device tree to github. That way we can see what you're doing and help better. Like was already said, the tree as is won't work.
 
BlaqueDroid
Old
#6  
BlaqueDroid's Avatar
Senior Member - OP
Thanks Meter 418
Posts: 218
Join Date: Oct 2013
Location: Johannesburg

 
DONATE TO ME
Quote:
Originally Posted by PonsAsinorem View Post
Also, it'd help if you uploaded your changes/device tree to github. That way we can see what you're doing and help better. Like was already said, the tree as is won't work.
Hey MAn thanks for the advice i managed to fix the device tree issue but now im stuck with this error ....any ideas

Code:
Copy xml: /home/blaquesoul/android/omni/out/target/product/i9500/system/etc/permissions/android.software.sip.voip.xml
make: *** No rule to make target `/configs/audio_effects.conf', needed by `/home/blaquesoul/android/omni/out/target/product/i9500/system/etc/audio_effects.conf'.  Stop.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Increase Your Multitasking Workflow with C-Floating Windows

Technology has put life on the fast track. Lazy, relaxed days have turned into … more

Compile Your Own Kernel From Source with Comprehensive Tutorial

One glance at any developer section of any device forum on XDA and youll find … more

WowWee Mip – Android Accessory Review – XDA Developer TV

The holidays will be here in no time, so why not start thinking about … more

Stream Your Media Files with the New Version of Droid Sync Manager

Android is a Linux-based operating system, but this fact doesn’t put … more