Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] i9500 S4 unsupporting Class 10 SD card

OP K3n2

23rd January 2014, 12:23 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Aug 2012
Hi,

I've recently purchased a SanDisk Class 10 32GB SD card for my SAMSUNG S4 i9500.
I have transferred some images and music from old SD card to new one and everything worked perfectly, just until one point when the device just unmounts the SD card and all files seems unaccessible, mounting it again and reinserting the card fixed the problem but it keeps unmounting suddenly, then at one point everything was moved to LOST.DIR. I have formatted the Card to FAT32 on PC then format it again using phone, but still same problem occurring, only now it shows that SD space is being used, still when browsed through on phone, it shows no data at all.

Does i9500 NOT support Class 10, or something wrong with SD card, any body had such experience?
23rd January 2014, 02:35 PM   |  #2  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Aug 2013
Quote:
Originally Posted by K3n2

Hi,

I've recently purchased a SanDisk Class 10 32GB SD card for my SAMSUNG S4 i9500.
I have transferred some images and music from old SD card to new one and everything worked perfectly, just until one point when the device just unmounts the SD card and all files seems unaccessible, mounting it again and reinserting the card fixed the problem but it keeps unmounting suddenly, then at one point everything was moved to LOST.DIR. I have formatted the Card to FAT32 on PC then format it again using phone, but still same problem occurring, only now it shows that SD space is being used, still when browsed through on phone, it shows no data at all.

Does i9500 NOT support Class 10, or something wrong with SD card, any body had such experience?

It does support Class 10 cards, I've been using a 64GB Lexar one for about 5 months now with no issues whatsoever.
24th January 2014, 10:30 AM   |  #3  
Member
Thanks Meter: 19
 
67 posts
Join Date:Joined: Nov 2013
More
Quote:
Originally Posted by K3n2

Hi,

I've recently purchased a SanDisk Class 10 32GB SD card for my SAMSUNG S4 i9500.
I have transferred some images and music from old SD card to new one and everything worked perfectly, just until one point when the device just unmounts the SD card and all files seems unaccessible, mounting it again and reinserting the card fixed the problem but it keeps unmounting suddenly, then at one point everything was moved to LOST.DIR. I have formatted the Card to FAT32 on PC then format it again using phone, but still same problem occurring, only now it shows that SD space is being used, still when browsed through on phone, it shows no data at all.

Does i9500 NOT support Class 10, or something wrong with SD card, any body had such experience?

I am also using Scandisk 32GB Class 10 sdcard but don't have any problems. Why not you try factory resetting the phone or upgrading the firmware. Best of luck...
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes