Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,808,657 Members 43,467 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia V not detected in Windows 8.1

Tip us?
 
LeParkour012
Old
#1  
LeParkour012's Avatar
Senior Member - OP
Thanks Meter 187
Posts: 1,488
Join Date: Feb 2011
Location: Singapore
Plug [Q] Xperia V not detected in Windows 8.1

My Xperia V is not being detected in Windows 8.1. It's only detected when using MTP or MSC, not Flash mode of fastboot mode. Before you start throwing "You must disable Driver signature enforcement" at me, flash and fastboot works for my Xperia Z1. I'm trying to relock my Xperia V's bootloader so I could give it to my uncle. Look at the attachment to see what message I got from Windows when connecting.

At first I thought having CM11, 4.4 kitkat was the problem. So I flashed a stock-based rom and kernel. Still no success.
Attached Thumbnails
Click image for larger version

Name:	Untitled.png
Views:	938
Size:	3.5 KB
ID:	2536365  
My Devices:
 
LaZiODROID
Old
#2  
LaZiODROID's Avatar
Senior Member
Thanks Meter 158
Posts: 666
Join Date: Feb 2011
Location: Toronto
That's interesting, as I've read a few times in different threads that Windows 8.1 simply won't allow the fastboot/flashmode drivers to be installed correctly (even with disabling Driver Signature Enforcement). I assume you have tried using different USB ports on your machine (and possibly even a different cable?)
 
russell664
Old
#3  
russell664's Avatar
Recognized Contributor
Thanks Meter 2,285
Posts: 1,172
Join Date: Dec 2010
Location: Somewhere you can't imagine...

 
DONATE TO ME
It does not work on windows 8.1, due to Microsoft changing the USB stack to their own prohibitory driver. Microsoft have announced that there will be a fix in Feb, lets hope they keep to their word.

I have broken my windows 8.1 install many times trying to hack the USB stack, with Windows 8 specific drivers, but it's a no go. I guess we will all have to wait until the is an official fix from Microsoft in this respect.
Have A Bug with one Of my Roms? Look below on how to report them to me....

 
If you have a bug, report it with a logcat because, without one I can't do anything about it. No Logcat, Means No Fix. Do this below to get one...

Code:
adb shell dmesg ; adb logcat -b system -b radio -b events -b main


Nexus 5/ Self Compiled PAC-ROM/ Chaos Kernel V11 Nightly

The Following User Says Thank You to russell664 For This Useful Post: [ Click to Expand ]
 
LeParkour012
Old
#4  
LeParkour012's Avatar
Senior Member - OP
Thanks Meter 187
Posts: 1,488
Join Date: Feb 2011
Location: Singapore
I don't get why I can get my Xperia Z1 to connect but not my Xperia V :/

Sent from my C6903 using Tapatalk
My Devices:
 
LaZiODROID
Old
#5  
LaZiODROID's Avatar
Senior Member
Thanks Meter 158
Posts: 666
Join Date: Feb 2011
Location: Toronto
The Z1 is a year newer than the V... Maybe sony made the Z1 fastboot and flashmode more compatible with win8.1?


Sent from my LT30at using XDA Premium 4 mobile app
 
LeParkour012
Old
#6  
LeParkour012's Avatar
Senior Member - OP
Thanks Meter 187
Posts: 1,488
Join Date: Feb 2011
Location: Singapore
Could be :/

Sent from my C6903 using Tapatalk
My Devices:
Tags
drivers, windows 8.1, xperia v
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes