Default ok Google how to enable it in kitkat

its one of the best feature of kitkat
but in cynogenmod 11 rom its not working
but i enabled it in this way if any one facing this problem then go this way

1) keep backup of both apks Google home apk (Google experience launcher) and velvet apk (Google search) in sd card

2) unistall both Google home apk(Google experience launcher) and google search now( velvet apk) by root unistaller
or manual deletion by root explorer via root >system >apps>delete Google home apk
for velvet apk go to system > pri-apk>delete velvet. apk
3)now first install velvet. apk as normal apk(not a system app)
4)open it activate Google now >set language to English (us) >
go to settings >voice >enable hotword detection
note: ok Google only support English us lauage it will not work for any other language
5)now install Google home apk as normal apk ( not as system app)
that's it now u can use ok Google just say ok Google and voice search is active
note: ok Google only works in Google search app and on home screen not any where like moto x




Sent from my GT-I9070 using xda premium
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-01-26-22-59-54.jpg
Views:	432
Size:	22.4 KB
ID:	2540648  

My phone galaxy s advance I9070]

CAME BACK TO. MACLAW STUDIO CM 11 WITHOC KERNEL 3. 0. 31 by t4n017 RR rom

IF HELPED U JUST PRESS THANKS button
IT MAKE ME FEEL HAPPY THAT I HELPED SOMEONE]