Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

int2ext won't install

OP sven31415

25th January 2014, 02:25 AM   |  #1  
OP Junior Member
Thanks Meter: 5
 
25 posts
Join Date:Joined: Nov 2013
Hello,

i installed AORP kitkat 4.4.2 on xperia ray and everything is ok.
I just want to install int2extv2+ script.
I tried to install the update zip file and it does not install (error status 0)
I try to copy the 40int2ext by hand to /etc/init.d and fix permission to 0755 and ghroup to shell with cm file exploerer.
After that i reboot and wipe data partition but the phone won't start. I hangs on the boot screen (which still rotate).

I have no clue how to get more information what is happening.

I formated /system and reinstalled the ROM to get back into the system but i checked /data for a log but i didn't found one. I suspect that 40intext did not start for some reason.

Maybe someone of you already did that with kitkat 4.4.2 and has an idea.

BR

Sven
26th January 2014, 10:57 PM   |  #2  
OP Junior Member
Thanks Meter: 5
 
25 posts
Join Date:Joined: Nov 2013
Hi,

i found a solution. It works for me now with AORP 1.2 on xperia ray.
The post that pointed me to it is here:
http://forum.xda-developers.com/show...2577975&page=4
Modify the current 40int2ext from int2extv2+ package with the following patch and put it into /etc/init.d using CM fileexplorer amd reboot.

If a directory is not properly copied you have to wipe/factory reset and then everything worked fine for me. I guess it is because the script uses "mv" to move the data. I guess a cp -aR and a rm -rf after checking would have been a better solution but i had no time to check.

I added app-lib directory because it seemed to be missing for kitkat.

--- CronMod-INT2EXTV2+/system/etc/init.d/40int2ext 2013-02-28 18:36:42.000000000 +0100
+++ todevice/40int2ext 2014-01-26 22:29:45.000000000 +0100
@@ -10,6 +10,8 @@
VER=INT2EXTV2+
LOG=/data/$VER.log

+busybox sleep 2
+
## Only continue if mmcblk0p2 exists
if [ ! -e /dev/block/mmcblk0p2 ]
then
@@ -57,7 +59,7 @@
busybox mv /sd-ext/$VER.log /data;

## Move existing files
-for i in app app-private dalvik-cache;
+for i in app app-private dalvik-cache app-lib;
do
if [ ! -e /data/$i ]
then

Unfortunatly i can neither post in the ROM thread nor in the int2ext thread as my postcount is too low. So i post here.

BR

Sven
27th January 2014, 03:13 AM   |  #3  
Senior Member
Thanks Meter: 34
 
187 posts
Join Date:Joined: Apr 2012
Use. Mount2sd

Sent from my Xperia Mini using xda app-developers app
The Following User Says Thank You to riyasopr For This Useful Post: [ View ]
27th January 2014, 11:38 AM   |  #4  
OP Junior Member
Thanks Meter: 5
 
25 posts
Join Date:Joined: Nov 2013
6236552 1138
Quote:
Originally Posted by riyasopr

Use. Mount2sd

Sent from my Xperia Mini using xda app-developers app

Thanks,
it looks very goo.
I will use it when i update to AORP 2.0
Currently it is working so no need to change.

BR

Sven
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes