5,604,122 Members 48,956 Now Online
XDA Developers Android and Mobile Development Forum

T-Mobile Wi-Fi Calling Problems

Tip us?
 
Howie Dub
Old
#1  
Senior Member - OP
Thanks Meter 46
Posts: 172
Join Date: Apr 2011
Default T-Mobile Wi-Fi Calling Problems

I'm having a couple of issues with Wi-Fi Calling and wanted to see if anyone else is experiencing the same. Whenever my phone goes into deep sleep, I don't receive any calls through Wi-Fi Calling. If a push notification comes through, Wi-Fi Calling will work again until the phone goes back into deep sleep. I have Wi-Fi always on in Wi-Fi settings, but that doesn't seem to work. The only thing that works is an app called Regpon WiFi Keep Alive, which prevents the phone from going into deep sleep. It works great, but it drains the battery. Appears to be a software issue since Wi-Fi Calling works fine when Regpon is on.

The other issue is when someone calls in, they sometimes will hear an echo on their end, but the call sounds fine for me. I'll call back and it's fine. I've brought these issues up to T-Mobile Customer Support, but they just regurgitate the same turn off router and wifi, turn on router and wifi, factory reset, etc. If anyone has a remedy to these issues, particular the deep sleep issue, it would be greatly appreciated. Thanks.
 
code hustler
Old
(Last edited by code hustler; 5th January 2014 at 11:20 PM.)
#2  
Junior Member
Thanks Meter 11
Posts: 13
Join Date: Nov 2013
Location: Yonkers, NY
try this:

Settings > Wi-Fi
hit the MENU > Advanced Wi-Fi

change "Keep Wi-Fi on during sleep" to "Always"

hope that helps!

EDIT: sorry, just realized you tried that. I can confirm the echo issue, happens once in a while, people complain about it "sounding weird" and I turn off Wi-Fi calling and call them back and it's resolved. Never had that issue with my HTC One S w/ WiFi-Calling so I'm not sure where the problem lies.
 
Howie Dub
Old
#3  
Senior Member - OP
Thanks Meter 46
Posts: 172
Join Date: Apr 2011
Quote:
Originally Posted by code hustler View Post
try this:

Settings > Wi-Fi
hit the MENU > Advanced Wi-Fi

change "Keep Wi-Fi on during sleep" to "Always"

hope that helps!

EDIT: sorry, just realized you tried that. I can confirm the echo issue, happens once in a while, people complain about it "sounding weird" and I turn off Wi-Fi calling and call them back and it's resolved. Never had that issue with my HTC One S w/ WiFi-Calling so I'm not sure where the problem lies.
Thanks code hustler. Just ran Better Batter Stats and there's an Android System partial wakelock called WifiDelayOffIfNotUsed. I wonder if this could be the reason why?
 
SmiLey497
Old
#4  
SmiLey497's Avatar
Senior Member
Thanks Meter 315
Posts: 775
Join Date: May 2009
Location: SF, CA - NYC
Try turning off Wi-Fi optimization in Wi-Fi settings

Sent from my LG-D801 using Tapatalk
Past Cellphones:
Motorola: Timeport, Droid 1
Sharp: Z800
Nextel: i710, i860
Apple: iPhone 4
Samsung: a950, SCH-i760, Galaxy Nexus, Galaxy S III, Galaxy Note II, Galaxy S 4
LG: Nexus 5, G2
HTC: Libra, Droid Eris, Incredible, Thunderbolt, One XL, One M7


Currently owned: HTC One M8
 
Howie Dub
Old
#5  
Senior Member - OP
Thanks Meter 46
Posts: 172
Join Date: Apr 2011
Quote:
Originally Posted by SmiLey497 View Post
Try turning off Wi-Fi optimization in Wi-Fi settings

Sent from my LG-D801 using Tapatalk
I have that unchecked as well, still the same. T-Mobile says it's the phone, but it must be the software if it works when it doesn't go into deep sleep, right? I can't imagine it being hardware related.
 
louptech
Old
#6  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jan 2014
Default WiFi Calling Falls Asleep, Inbound Echo

I have the exact same symptoms on the LG G2 I just purchased. Been trouble shooting it for a couple of weeks. At least 50% of inbound calls go to voicemail unless phone was just used. WiFi calling icon is often red for 1/2 second when waking phone up. Phone never shows missed call, no ring occurs for caller or recipient and call goes directly to voicemail as if phone is off of network. Notification of voicemail is virtually instantaneous after caller hangs up from leaving message. Also, inbound calls have bad echo for the caller. I've tried multiple networks, always the same and it only happens on LG G2. I'm also using latest release of system from LG as of 1/9. As an aside, outbound calls work reasonably well, but do occasionally just drop, forcing me to redial tech support or whoever.

T-Mobile won't acknowledge that it is a known issue even after over 20 calls. Techs won't look into the problem or respond when they say they will look into it and get back within 72 hours. They blame the router or even tell me to call LG. LG says they only make hardware and base os and that wifi calling feature is T-Mobile's to support and I agree with them.

Since I depend upon wifi calling, this phone is going back. T-Mobile has been screwing people over with this phone's wifi calling for at least 2 months. I'm out of 14 day trial period due to extensive trouble shooting so must pay for 'service' but hopefully I'll get price of phone back as I plan to return through Costco and port number back out of T-Mobile. Unlike T-Mobile, Costco typically stands behind their customers which is why I shop there.

This is a great piece of hardware, although a bit pricy at this point. Until WiFi calling works though, for me it isn't worth the price for the handset plus service.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Wearables Walkthrough: Tasker on the Samsung Galaxy Gear – XDA Developer TV

The future certainly looks like it is full of wearables. … more

WinDroid HTC Toolkit Lets You Root, Unlock, and Flash ROMs on Various HTC Devices

Plenty of users nowadays have more than one mobile device. … more

When Using GitHub, Don’t Skimp on Commit History

GitHub has become the epicenter of most open source development work that is posted … more

Verizon Droid DNA to Receive 4.4.2 KitKat + Sense 5.5 OTA This Thursday

The HTC Droid DNAis Verizon’s close cousin to the JapaneseHTC … more