An Android Enthusiast’s Apple iPhone 6 Challenge

The media has gone batty again over Apple “revolutionizing” smartphones. … more

Sony to Extend its AOSP Program to Other Devices

Sony will be offering its users the possibility to use AOSP ROMs as an alternative to the … more

Project Ara: Modified Android L and Hot Swapping

Project Ara is a very exciting topic–both for hardware and software enthusiasts. The … more

Streamline Android Theming with Graphic Porter

I dont have a custom theme on my Android phone, and the reason for this is because I am too … more
Post Reply

Error 927, And All Potential Solutions Have Failed...

28th January 2014, 04:10 AM   |  #1  
OP Member
Thanks Meter: 3
 
76 posts
Join Date:Joined: Jan 2012
Here it is in a nutshell: Error 927 on ANY download, any app, any game, be it paid or free, on my Nexus 7 (2013) FHD. I've done the following:

- Cleared the data and cache for the Google Play Store, Download Manager, and Google Services Framework.

- Uninstalled updates for the Google Play Store and Google Services Framework.

- Deleted and re-added my Google account.

- Rebooted.

- Hard reset.

- Downgraded to 4.3 and re-upgraded to 4.4.2.

- Tried to download the apps and games from the Google Play website, and get "An unexpected error has occured. Please try again later."

- Changed the filter and proxy settings on my Cisco router.

- Switched to LTE, and... same thing.

- Created another Google account, and it worked, but I will NOT be forced to re-purchase the apps I've spent nearly $80.00 on over the years, or upload my music collection to Google Music again.

- Reached out to Google for help, and... crickets.

I'm at the end of my rope. If this isn't resolved soon, I'm returning the Nexus to Wal-Mart. I've NEVER had this sort of issue before, even with my first-generation Nexus 7. I've had Android tablets since my Motorola Xoom awhile back. I've ALWAYS had Android tablets. I'd hate to have to abandon Android because of this idiocy, but I may have to do so. I don't want to have to go with Apple for both my smartphone and tablet, but it's starting to look that way.

If anyone has any suggestions that aren't listed above, please, help me out. I love my Nexus 7, but without apps and games, it's pretty worthless.

Thanks in advance.
28th January 2014, 05:55 AM   |  #2  
Pandae's Avatar
Senior Member
Thanks Meter: 54
 
212 posts
Join Date:Joined: Dec 2013
Normally deleting and adding back the Google account is a solution for Play Store problems, but as you said, you tried that. Some have reported that error 927 is because of a network connection error. How is web browsing? YouTube?

Quote:
Originally Posted by abarax

- Downgraded to 4.3 and re-upgraded to 4.4.2.

How did you do that? Did you download the 4.3 ROM to flash it? Did you unlock and flash a custom recovery?

When all else fails, flash the stock ROM, especially with your downgrading and upgrading. Google's files include a "flash-all.bat" within that will wipe everything and flash the stock ROM and recovery.

https://developers.google.com/androi...s/images#razor
28th January 2014, 09:28 AM   |  #3  
OP Member
Thanks Meter: 3
 
76 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by Pandae

Normally deleting and adding back the Google account is a solution for Play Store problems, but as you said, you tried that. Some have reported that error 927 is because of a network connection error. How is web browsing? YouTube?

All web browsing and pre-installed apps work just fine. Just any attempts to update those apps, or install any other apps from Google Play, fail with error 927.

How did you do that? Did you download the 4.3 ROM to flash it? Did you unlock and flash a custom recovery?



When all else fails, flash the stock ROM, especially with your downgrading and upgrading. Google's files include a "flash-all.bat" within that will wipe everything and flash the stock ROM and recovery.



https://developers.google.com/androi...s/images#razor

I actually have flashed the stock ROMs, from the original 4.3 to 4.4.2, with the exact same results. I've also made certain not to unlock the bootloader and to not root as to recreate the OOB experience as well. At this point, my options are exhausted.
28th January 2014, 10:54 AM   |  #4  
Dexxon's Avatar
Member
Flag Dörentrup
Thanks Meter: 17
 
83 posts
Join Date:Joined: Mar 2013
Quote:
Originally Posted by abarax

I actually have flashed the stock ROMs, from the original 4.3 to 4.4.2, with the exact same results. I've also made certain not to unlock the bootloader and to not root as to recreate the OOB experience as well. At this point, my options are exhausted.

Are you able to install apps on another device with the same account? If not it may be a problem with your account...
The Following User Says Thank You to Dexxon For This Useful Post: [ View ]
29th January 2014, 05:41 PM   |  #5  
zombieguy85's Avatar
Senior Member
Flag Waco ,tx
Thanks Meter: 43
 
278 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by Dexxon

Are you able to install apps on another device with the same account? If not it may be a problem with your account...

I know his pain I have flashed reflashed installed stock and im using a atrix 2 with ics 4.0.4

im hoping its a google server problem and it will be fixed
29th January 2014, 10:49 PM   |  #6  
parmend's Avatar
Senior Member
Fort Worth
Thanks Meter: 58
 
840 posts
Join Date:Joined: Apr 2010
More
I was having the same problem for the last two days and I went to settings/Google account and noticed there was a sync error with sound search for Google play and I manually synced it and now apps download .

Sent from my Nexus 5 using Tapatalk
29th January 2014, 11:51 PM   |  #7  
zombieguy85's Avatar
Senior Member
Flag Waco ,tx
Thanks Meter: 43
 
278 posts
Join Date:Joined: Feb 2011
More
I went into my account removed my devices from it on the web and signed in on my phone now it works

Sent from my MB865 using Tapatalk
30th January 2014, 08:03 PM   |  #8  
dawiseguy77's Avatar
Senior Member
Thanks Meter: 134
 
856 posts
Join Date:Joined: Dec 2010
I've been having the exact same issue for 4 days. Regardless of rom, phone, or gmail account I use. I've done every wipe format imaginable even Odin as I have a Samsung phone same issue. Now I cant even get any Google apps to connect at all. Such as Google plus play store YouTube etc...Google says never heard of it before sorry.
31st January 2014, 03:04 AM   |  #9  
Senior Member
Flag Fort Worth, TX
Thanks Meter: 101
 
636 posts
Join Date:Joined: May 2007
More
Quote:
Originally Posted by dawiseguy77

I've been having the exact same issue for 4 days. Regardless of rom, phone, or gmail account I use. I've done every wipe format imaginable even Odin as I have a Samsung phone same issue. Now I cant even get any Google apps to connect at all. Such as Google plus play store YouTube etc...Google says never heard of it before sorry.

I'm having the exact same problem now for a few days. I called Google support and they are aware of the problem and had no resolution. I was told too bad basically.

Out of curiosity, for those having this issue, did you upgrade to a 4.4.2 ROM?
31st January 2014, 03:42 PM   |  #10  
dawiseguy77's Avatar
Senior Member
Thanks Meter: 134
 
856 posts
Join Date:Joined: Dec 2010
I updated to stock rooted 4.3 galaxy note 2 Verizon and it happens on all of my gmail accounts too

Sent from my SCH-I605 using Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Nexus 7 (2013) Q&A by ThreadRank