5,596,179 Members 34,091 Now Online
XDA Developers Android and Mobile Development Forum

[Q] I've messed up terribly. Galaxy S4 Odin firmware flash went wrong.

Tip us?
Lavell7298's Avatar
Senior Member
Thanks Meter 221
Posts: 274
Join Date: Feb 2011
Location: Spring, TX
Pull the battery out of the phone, then put it back in and try to boot into recovery again. Sometimes, the recovery will hang like you described. You might have to repeat this process again and again until you get into the main menu of the recovery.
Samsung T-mobile Galaxy S4 (Rooted)
dbombROM v3.4
KT-SGS4 JB 4.3 kernel 04.07.2014
TWRP Touch Recovery v2.6.3.1

HTC T-mobile Sensation 4G (S-Off, Super CID, Rooted)
CoreDroid Sensation ROM v6.0
Bricked Kernel v1.4 Oc'd to 1.83GHz
4EXT Recovery Touch v1.0.0.5 RC9
Radio v11.76C.3504.00P_11.29A.3504.18_M
RIL 4.0.0017HMQ
Firmware v3.33.401.106

T-mobile MMS Fix for Sensations
Easily Update Radios & RIL Files on Sensations
Great Speed & Battery Life with 2 CPU Cores!
The Following User Says Thank You to Lavell7298 For This Useful Post: [ Click to Expand ]
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Jan 2014
Okay, so I'm sure I'm doing everything right. I flashed the twrp recovery it restarts my phone. I held the power key, home key, and up key on the phone and released the power button when it shows the text on the top left showing that it is going to start recovery. It goes to a "teamwin" screen but freezes there. Truthfully, do you think I will be able to recover my phone, or will I need to send it in to samsung and pay 70 dollars plus the damages?
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Jan 2014
Originally Posted by Misterjunky View Post
Flash this TWRP custom recovery in ODIN then go into recovery mode and
do a full wipe, data, system, dalvik cache, cache and do a Factory Reset.
Here is the direct download link for the Odin flash TWRP recovery:

Once that's done go into download mode and flash the
stock official M919 4.2.2 firmware (tar/md5) file.

Good luck!
Do you think the reason why I can't flash the firmware is because I upgraded to 4.3 and it brought KNOX onto the phone?
Thanks Meter 3
Posts: 53
Join Date: Oct 2012
Location: Houston
Originally Posted by NEKTAR11 View Post
Okay, so I rooted my phone back in December and had no problems at all with firmware 4.3. I had this app called "Clean Master" I think, so it analyzed my device to clean up "unnecessary" files and such. I go ahead a clean whatever it had "cleaned" and then I noticed that when I went into settings that it started freezing for about a minute or so and had to force close the settings. It also started to restart randomly at times and it got to the point where I just got fed up and looked to the internet. I decided to use Odin to Unroot my phone because at the time that's what I thought was causing the problem. This is where I think (I know) I screwed up. Instead of flashing the stock firmware for the T-Mobile Galaxy s4 I flashed this "GT-I9500-XSE-I9500XXUAME1-ROOTED_MAY4". I think I used this file for rooting but I downloaded so many files to get the rooting to work that I don't remember. This file is neither an .md5 file nor a .tar file. I don't know what I was thinking and I regret the decision. I started the transfer of whatever file that was to my phone using the Custom ROM download screen, and it only took about 4 seconds and said it passed. It reboots but ever since has been stuck on the Samsung Galaxy s4 screen. Recently it now says "Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again. I've tried connecting the device via Kies but IT DOES NOT CONNECT. I'm beginning to think that I've just completely destroyed the phone and will be needing to by another. Any help would be much appreciated. I've tried everything I know. I've wiped the cache, wiped the data and factory reset the phone, but it won't reboot correctly. I'm stuck people. What can I do?
Are you sure some other people have tried this file on a t-mobile variant? because GT-I9500 is indeed for a galaxy s4, but it's for the octa chipset, which is completely different from the t-mobile variant of the s4 since the t-mobile version is similar to GT-I9505, which is a quad core instead of a octa core
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Jan 2014
Just to give you guys a heads-up, I fixed my phone, but not by the ways you guys suggested. Not that I'm ungrateful, I am very happy you all took the time to help me out and I appreciate the suggestions. Thank you so much.

Oh and I fixed it by going into kies, clicking on "tools", "firmware upgrade and initialisation", and proceeded to follow the steps and type in my Model name and Serial Number.Fortunately they had the ability for my phone to return it COMPLETELY stock.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes