Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,779,159 Members 46,083 Now Online
XDA Developers Android and Mobile Development Forum

**How to activate full 3G coverage in US (t-mobile/att)

Tip us?
 
avetny
Old
(Last edited by avetny; 12th January 2014 at 12:14 AM.)
#1  
avetny's Avatar
Senior Member - OP
Thanks Meter 1592
Posts: 4,970
Join Date: Jul 2010
Location: Private Island.
Default **How to activate full 3G coverage in US (t-mobile/att)

I got F340K (F340L also tested) unit from Korea. Which is supposed to work everywhere on 3G in US T-Mobile (and on AT&T I guess)
but I faced with problem when the phone almost everywhere stuck on 2G. The problem located not in APN settings. We just need to manually enable write bands

How to fix it:

1) Type in dialer: 5457#*340#
2) Click on: Band selection.
3) Mark on: LTE B1 (2100), LTE B3 (1800), LTE B8(900). Do not touch other marks.
4) Press: Save

Phone will reboot. Now you got full 3G coverage everywhere you go.
The Following User Says Thank You to avetny For This Useful Post: [ Click to Expand ]
 
barondebxl
Old
#2  
barondebxl's Avatar
Senior Member
Thanks Meter 1476
Posts: 6,155
Join Date: Jul 2011
Location: Silver Spring, MD
Awesome! This is good to know

Sent from my LG-D800 using Tapatalk
Jack Bauer is back!!!!!!!!!

Current Device: OnePlus One

Recently Owned


HTC One M8

Sony Xperia Z2

Samsung Galaxy S 5

Oppo Find 7a
 
Jaba04
Old
#3  
Junior Member
Thanks Meter 4
Posts: 26
Join Date: Apr 2009
Hi guy's !!
What's the USSD code for D958 please..?
When i type : 5457#*958# the phone say "code USSD not valid" ???!!!!
Thanks
The Following User Says Thank You to Jaba04 For This Useful Post: [ Click to Expand ]
 
lleung215
Old
#4  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jan 2014
Default Help--urgent with my LG G FLEX

Quote:
Originally Posted by avetny View Post
I got F340K (F340L also tested) unit from Korea. Which is supposed to work everywhere on 3G in US T-Mobile (and on AT&T I guess)
but I faced with problem when the phone almost everywhere stuck on 2G. The problem located not in APN settings. We just need to manually enable write bands

How to fix it:

1) Type in dialer: 5457#*340#
2) Click on: Band selection.
3) Mark on: LTE B1 (2100), LTE B3 (1800), LTE B8(900). Do not touch other marks.
4) Press: Save

Phone will reboot. Now you got full 3G coverage everywhere you go.

I'm so sorry..I'm really new to this and I think I had the same problem as above when I purchased an unlocked LG G Flex phone from Hong KOng and try to use it on ATT when I return to U.S. and that the speed is really slow when I had my apn on HSPA+ with the following info

APN: phone
mssc: UNABLE TO SHOW
mms proxy: proxy.mobile.att.net
mms port: 80
mcc: 310
mnc: 410
apn type: default, supl,mms,hipri
apn protocol: ipv4

The question is what is a "dialer" and where I put it on the phone? Or other things I need to know to fix my problem please?

Thanks!

larry
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes