5,599,033 Members 31,994 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia X10i Bricked !

Tip us?
 
asciisort
Old
#11  
Junior Member - OP
Thanks Meter 2
Posts: 12
Join Date: Jan 2014
Quote:
Originally Posted by Dr Goodvibes View Post
Your phone indicates an unlocked bootloader, just for your information.

What's the thoughts on the battery? Was it in a good service state?

Take the battery out of the phone for 48 hours and then put it back in the phone and power the phone on.

The green light for a few seconds indicates the phone is attempting, or in a recovery state.

Your phone may have just had a 'moment' and has a "locked instruction", that just needs to be cleared with no power applied to the chipset.

This has worked for others and is more voodoo than science, but worth a try.
Update Number 2 : Hey, after completely keeping aside the battery for more than 24 hours, I connected the device to external wall DC supply (while battery was removed and never inserted after the 24 hours interval that is). After connecting the device to DC wall supply, it gave me the same response, flicked and showed green light and then vibrated and then nothing ! F1 !!!
 
asciisort
Old
#12  
Junior Member - OP
Thanks Meter 2
Posts: 12
Join Date: Jan 2014
Quote:
Originally Posted by Dr Goodvibes View Post
Your phone indicates an unlocked bootloader, just for your information.

What's the thoughts on the battery? Was it in a good service state?

Take the battery out of the phone for 48 hours and then put it back in the phone and power the phone on.

The green light for a few seconds indicates the phone is attempting, or in a recovery state.

Your phone may have just had a 'moment' and has a "locked instruction", that just needs to be cleared with no power applied to the chipset.

This has worked for others and is more voodoo than science, but worth a try.
Update 3: http://talk.sonymobile.com/t5/Xperia...to/td-p/273134
Just Googled my problem and came to this link. I can very much relate to the link although, His device was water locked, (there was this small white rectangle, if it is water damaged then it will be red) Surprisingly, his device which was water damaged shows the same symptom as mine. So, i checked mine, but the sticker or white rectangle for moist / humidity checker is white totally. So I guess it can't be water damaged, although, it showed the same symptoms !
 
asciisort
Old
#13  
Junior Member - OP
Thanks Meter 2
Posts: 12
Join Date: Jan 2014
Quote:
Originally Posted by Dr Goodvibes View Post
I would have placed the battery back in the phone and pressed the power button and see if it booted, or allowed you to get to CWM Recovery with blue light or xRecovery(if installed).

One day, one week. How long does residual power remain in a circuit board to hold the current date/time before resetting?

Maybe buy a cheap BST-41 1500mAh battery for the XPERIA X10 and try that. Could be just a bad battery.
You could check the battery with a multimeter and see if it still has a charge.

My knowledge base stops at this point as I have no experience beyond this.

Good luck.
Update Number 4: Since green Light was always On, I thought what if its in flash mode and much to my surprise, the device is in Flash Mode when I switch it on, how I found out : While flashing via SEUS, I didnt press the back key and the device got connected in flash mode by default, So i narrowed down the problem to something that : My device boots to Flash mode and not as it normally should ? Is it a mother board problem ? Can it be cured ? (god no please not mother board problem) So ? Any thoughts anyone to make it come out f the flash mode. ?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes