Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,791 Members 53,747 Now Online
XDA Developers Android and Mobile Development Forum

problems writing to FAT32 using TF700T

Tip us?
 
Flabs
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jan 2014
Tablet problems writing to FAT32 using TF700T

Hi,

I am using ASUS TF700T infinity pad and tried to copy some mp3 (so nothing big) onto micro SD to use the SD in some external mp3 player.
Unfortunately I was unable to "see" that files I copied using the tablet on several different players (mp3 player, car radio,...).
Interesting is that my windows pc sees the files on the SD without any issues.

If I copy the exact same mp3 file using a windows pc to the same micro SD and insert it into the same player than used before - I can see and play the files without any problem.

I used the internal micro SD slot, the SD slot in the dock (so several micro SD / Adapter and SD card itself combinations) - same result.
I just cannot get data out to a FAT32 filesystem using my TF700T (not sure yet, but I think I had similar issues when just connecting a usb stick with FAT32).

Seems that different end devices act a little different on that issue:
Whereby my mp3 player just does not display files I copied via TF700T to the SD (but shows all others I copied earlier using a windows pc),
my car radio refuses to show any content as soon as I copied one single file onto the SD.
As soon as I remove that single file from the SD, the car radio shows again all the other mp3's.

Some tests showed that the TF700T seems to have problems writing to FAT32 filesystem:
I copied a test file (mp3) using TF700T to a fresh (in windows) formatted FAT32 microSD and checked the filesystem using fsck in my linux pc.
It complains about "no short filename" for that file I just copied!
Fixing the filesystem issue results in ALL my tested players to start working with the SD and file(I can see the file, play it,...).
Windows does not seem to be that selective - I can see content without the need of "repairing" it first.

Here some facts about the tablet Infinity tablet I use:
Android 4.2.1
GPS v7.9.11
Wi-Fi v7.2.1.44
Bluetooth V11.33
Touchpanel ELAN-3024-7053
Kamera TF700T-B03400
Kernel 3.1.10-gb1a9af5
Build JOP40D.WW_epad-10.6.1.14.10-20130801
PAD-EC20T-0216
MobileDock DOCK-EC20N-0207

As somebody wrote to use cyanogenmod, I installed CM10.2.
Now I have Android 4.3 - but still the same issues!

Anybody having similar problems or some ideas how I can get thet running?
 
_that
Old
#2  
Recognized Contributor
Thanks Meter 2,390
Posts: 3,391
Join Date: Oct 2012
Quote:
Originally Posted by Flabs View Post
It complains about "no short filename" for that file I just copied!
Interesting. Very good first post, and welcome to XDA!

After some reading it looks like it's not a technical but a legal problem (don't we all love patent trolls), and this option needs to be set in the kernel config and the kernel recompiled:

Code:
CONFIG_VFAT_FS_DUALNAMES=Y
The Following User Says Thank You to _that For This Useful Post: [ Click to Expand ]
 
Flabs
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jan 2014
Thanks for this piece of information.

Well, this is kind of disappointing - other Tablets like Samsung Note worked without problems for this issue.
Is only Asus having those kind of "legal restrictions", or is it a common thing to have such? Never heard something like that before.

My motivation for buying this tablet was to "just use it" - no need to tweak or dig in things.
Reality showed something different (as always)

I assume that there's no chance to do such changes without deeper knowledge?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes