Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] [I9500] [4.3] GPSD Wakelock

OP chinoquezada

24th January 2014, 08:06 PM   |  #1  
OP Member
Flag Guayaquil
Thanks Meter: 6
 
48 posts
Join Date:Joined: Apr 2011
Hello all,

I'm having this recurring issue and I can't seem to solve it:
My I9500 S4 isn't going to deep sleep due to a GPSD Wakelock (as reported by BetterBatteryStats)

ROM: Wanamlite 3.9 JB 4.3
Kernel: Perseus

Things I've tried to solve it:

1. Froze (in Titanium Backup) most apps that uses network connectivity.
Haven't frozen Email (exchange corporate account from work) or gmail yet.

2. Deactivated all location settings.
No GPS, No Wirelss Network location, no location access to google apps, etc.

3. Wiped cache and dalvik cache
This solves the issue temporarily, but it returns within a few hours.

4. Factory Reset, Full Wipe and SD Card Wipe
Didn't solve a damn thing.

I'm attaching my BBS dumps.

If anyone has any idea about this, please help. I'm out of ideas

Thanks!
25th January 2014, 07:17 PM   |  #2  
OP Member
Flag Guayaquil
Thanks Meter: 6
 
48 posts
Join Date:Joined: Apr 2011
bump
31st January 2014, 09:00 PM   |  #3  
OP Member
Flag Guayaquil
Thanks Meter: 6
 
48 posts
Join Date:Joined: Apr 2011
Smile Solved!
Just a quick update, I managed to solve this problem by setting Network mode to WCDMA only.
After reading all over the net about GPSD battery drain, I concluded that my problem could be either caused by :
a. Misbehaving app (not my case) or
b. Radio interface problems (my case)

As it turns out, my local signal situation (Ecuador) is so "jumpy" that setting Network mode to Auto Connect, cause continuous GPSD wakelocks which didnt let my device go into deep sleep.
Post Reply Subscribe to Thread

Tags
bbs, gpsd, wakelock
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes