FORUMS

OnePlus 2 Announced: Specs, Price and Details

The OnePlus 2 has just had its Virtual Reality Launch event, and at the XDA Office we all … more

A Helpful Guide to Music Streaming Services

With the launch of Apple Music, music streaming services have recently gained a lot of … more

An Inside Look at the Redesign of Business Calendar

The much-acclaimed calendar app, Business Calendar, underwent a major design … more

New Android One Device Dead On Arrival

Today, Google announced the second generation of Android One devices, with the new Lava Pixel … more

Settings/About Device /Fix

44 posts
Thanks Meter: 1
 
By heylady40, Member on 1st February 2014, 10:26 PM
Post Reply Subscribe to Thread Email Thread
When is there going to be a fix for the Settings About Device Force closure.. Any eta. OR IS THERE A WORK AROUND.

Sent from my SM-P600 using XDA Premium 4 mobile app
 
 
1st February 2014, 10:35 PM |#2  
440bro's Avatar
Senior Member
Flag Cleveland ROCKS!!!
Thanks Meter: 442
 
Donate to Me
More
Quote:
Originally Posted by heylady40

When is there going to be a fix for the Settings About Device Force closure.. Any eta. OR IS THERE A WORK AROUND.

Sent from my SM-P600 using XDA Premium 4 mobile app


I have no idea what you are talking about. What rom version you're referring to? I don't get any force closures!
1st February 2014, 10:37 PM |#3  
OP Member
Thanks Meter: 1
 
More
I'm running Hyperdrive Rom on ATT NOTE 3. THIS IS MENTIONED AS ONE OF THE BUGS.

Sent from my SM-P600 using XDA Premium 4 mobile app
1st February 2014, 10:46 PM |#4  
440bro's Avatar
Senior Member
Flag Cleveland ROCKS!!!
Thanks Meter: 442
 
Donate to Me
More
Quote:
Originally Posted by heylady40

I'm running Hyperdrive Rom on ATT NOTE 3. THIS IS MENTIONED AS ONE OF THE BUGS.

Sent from my SM-P600 using XDA Premium 4 mobile app

Well if it's already mentioned as a bug, what are you trying to accomplish?
1st February 2014, 10:57 PM |#5  
OP Member
Thanks Meter: 1
 
More
Obviously I'm looking for fix or work around

Sent from my SM-P600 using XDA Premium 4 mobile app
2nd February 2014, 01:20 AM |#6  
TheDriller's Avatar
Senior Member
Flag Fort Collins, CO
Thanks Meter: 6,388
 
Donate to Me
More
Dude... Seriously? Did you really start ANOTHER thread about this?
If you want to fix it decompile secsettings.apk
Look for the smali that should be something like about_device.smali or something like that.
Open it in notepad++
Find .method oncreate
Scroll down to the first 0x7 hex
Then look in res>values>public.XML
Find the xml reference to the same smali file should be about_device or about_phone.xml or something like that.
Copy the hex code
Replace the code in the smali file with the one you copied from public.xml
Save and recompile
Sign the apk with test keys or old signature
Copy to system/app
Set permissions 0644
Wipe cache/dalvik
Reboot
Profit?
And then never make another thread about this again

Sent from my SM-N900A
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes