Make Calling Your Loved Ones Easier and Cheaper this Diwali

Diwali, or Deepawali as some Indians call it, is the pride and joy of Indian … more

Big Android BBQ 5.0 Recap – XDA TV

This fifth annual Big Android BBQ has come and gone. The speakers have spoke, the sponsors have … more

Microsoft to Counter “OK Google” with Bing Torque

When Microsoft is making apps for Android, users should be aware that something … more

Google Confirms “Android Lollipop Day” for November 3rd

A little over a week ago, Google announced the latest iteration of … more
Post Reply

Settings/About Device /Fix

OP heylady40

1st February 2014, 10:26 PM   |  #1  
OP Member
Thanks Meter: 0
 
31 posts
Join Date:Joined: May 2011
When is there going to be a fix for the Settings About Device Force closure.. Any eta. OR IS THERE A WORK AROUND.

Sent from my SM-P600 using XDA Premium 4 mobile app
1st February 2014, 10:35 PM   |  #2  
440bro's Avatar
Senior Member
Flag Cleveland ROCKS!!!
Thanks Meter: 420
 
1,204 posts
Join Date:Joined: Oct 2008
Donate to Me
More
Quote:
Originally Posted by heylady40

When is there going to be a fix for the Settings About Device Force closure.. Any eta. OR IS THERE A WORK AROUND.

Sent from my SM-P600 using XDA Premium 4 mobile app


I have no idea what you are talking about. What rom version you're referring to? I don't get any force closures!
1st February 2014, 10:37 PM   |  #3  
OP Member
Thanks Meter: 0
 
31 posts
Join Date:Joined: May 2011
I'm running Hyperdrive Rom on ATT NOTE 3. THIS IS MENTIONED AS ONE OF THE BUGS.

Sent from my SM-P600 using XDA Premium 4 mobile app
1st February 2014, 10:46 PM   |  #4  
440bro's Avatar
Senior Member
Flag Cleveland ROCKS!!!
Thanks Meter: 420
 
1,204 posts
Join Date:Joined: Oct 2008
Donate to Me
More
Quote:
Originally Posted by heylady40

I'm running Hyperdrive Rom on ATT NOTE 3. THIS IS MENTIONED AS ONE OF THE BUGS.

Sent from my SM-P600 using XDA Premium 4 mobile app

Well if it's already mentioned as a bug, what are you trying to accomplish?
1st February 2014, 10:57 PM   |  #5  
OP Member
Thanks Meter: 0
 
31 posts
Join Date:Joined: May 2011
Obviously I'm looking for fix or work around

Sent from my SM-P600 using XDA Premium 4 mobile app
2nd February 2014, 01:20 AM   |  #6  
RErick's Avatar
Recognized Contributor
Flag Fort Collins, CO
Thanks Meter: 4,807
 
3,085 posts
Join Date:Joined: Jan 2012
Donate to Me
More
Dude... Seriously? Did you really start ANOTHER thread about this?
If you want to fix it decompile secsettings.apk
Look for the smali that should be something like about_device.smali or something like that.
Open it in notepad++
Find .method oncreate
Scroll down to the first 0x7 hex
Then look in res>values>public.XML
Find the xml reference to the same smali file should be about_device or about_phone.xml or something like that.
Copy the hex code
Replace the code in the smali file with the one you copied from public.xml
Save and recompile
Sign the apk with test keys or old signature
Copy to system/app
Set permissions 0644
Wipe cache/dalvik
Reboot
Profit?
And then never make another thread about this again

Sent from my SM-N900A
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes