FORUMS

Can't Connect to Camera, Help?

93 posts
Thanks Meter: 3
 
By b1969, Member on 1st February 2014, 03:00 AM
Post Reply Subscribe to Thread Email Thread
Just got my phone fixed cause of the pint tint. However, now if I flash any ROM I cant connect to the camera I would always get "Can't Connect to Camera". CM, PA, AOKP, GPE all does not work. Haven't tried Stock ROM yet.

Is anyone else having this problem?
 
 
1st February 2014, 10:19 AM |#2  
n1234d's Avatar
Senior Member
Flag Mumbai
Thanks Meter: 446
 
More
Quote:
Originally Posted by b1969

Just got my phone fixed cause of the pint tint. However, now if I flash any ROM I cant connect to the camera I would always get "Can't Connect to Camera". CM, PA, AOKP, GPE all does not work. Haven't tried Stock ROM yet.

Is anyone else having this problem?

Go to /sys/android_camera/ and open the sensor file as text, what do you see there? Sounds like you've got the new Omnivision camera..
2nd February 2014, 01:30 AM |#3  
OP Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by n1234d

Go to /sys/android_camera/ and open the sensor file as text, what do you see there? Sounds like you've got the new Omnivision camera..

In the text file I see "ov ov4688 4M". What is omnivision camera?
2nd February 2014, 01:40 AM |#4  
n1234d's Avatar
Senior Member
Flag Mumbai
Thanks Meter: 446
 
More
Quote:
Originally Posted by b1969

In the text file I see "ov ov4688 4M". What is omnivision camera?

Till now, HTC used camera modules from ST Microelectronics (ST VD6869), but because of the purple tint problem, they shifted to Sharp modules, and now they're using Omnivision modules. The drivers for the Omnivision modules aren't included in the aosp roms you've been using, that's why the error. They've been included in Sense 4.2.2 onwards

Sent from my HTC One using Tapatalk
2nd February 2014, 02:00 AM |#5  
OP Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by n1234d

Till now, HTC used camera modules from ST Microelectronics (ST VD6869), but because of the purple tint problem, they shifted to Sharp modules, and now they're using Omnivision modules. The drivers for the Omnivision modules aren't included in the aosp roms you've been using, that's why the error. They've been included in Sense 4.2.2 onwards

Sent from my HTC One using Tapatalk

Is there a noticeable between the original and the omnivison modules? Will AOSP ever include drivers for omnivision?

Thank you.
2nd February 2014, 03:16 AM |#6  
cschmitt's Avatar
Senior Member
Thanks Meter: 1,942
 
More
Since 1/23 CM11 now includes the libs for ov4688.
Last edited by cschmitt; 2nd February 2014 at 03:20 AM.
2nd February 2014, 04:44 AM |#7  
OP Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by cschmitt

Since 1/23 CM11 now includes the libs for ov4688.

Thank you very much, it is sad that CM nightly has stopped uploading for m7 tmo at 1/6

EDIT: Nvm found this on the internet. "Starting tomorrow the m7ul, m7tmo, m7att builds will no longer be updated. They are now (finally) commonized to "m7". Please keep that in mind going forward."
Last edited by b1969; 2nd February 2014 at 04:52 AM.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes