FORUMS
Post Reply Subscribe to Thread Email Thread

Galaxy S3 charging issue

2nd February 2014, 03:24 PM |#1  
shahaf321's Avatar
OP Member
Flag Hadera
Thanks Meter: 3
 
More
Hello,
recently after getting my phone back from repair the device will either charge very slowly or doesnt charge at all
usually reconnecting the charger back solves the problem.

i have seen in the forum many people complaining about this issue but i have never seen a real answer for this..
i did rule out the possibility that the charger is flawed, the charger is fine i even baught a new one and tried multiple others.

so it must be either the phone hardware or.. maybe software?.. in case its software i did try reformating the device
but that didnt help at all.

my question is, would reflashing the rom be a possible solution?. i never did flash the rom its the stock one from the day i got it
and it has neevr been reflashed or anything just reformat.

i have no interest in custom roms unless its necesery.
thankyou
Last edited by shahaf321; 2nd February 2014 at 03:28 PM.
 
 
2nd February 2014, 04:46 PM |#2  
twistedillutions's Avatar
Senior Member
Flag 209
Thanks Meter: 354
 
More
Look at the usb port might be worn out or damage

Sent from my unknown using Tapatalk
2nd February 2014, 04:49 PM |#3  
shahaf321's Avatar
OP Member
Flag Hadera
Thanks Meter: 3
 
More
Quote:
Originally Posted by twistedillutions

Look at the usb port might be worn out or damage

Sent from my unknown using Tapatalk

i did and it looks fine, i even preordered one fromn ebay just in case this rly is the case, but first
i obviously want to rule out the software.
i dont want 2 deal with the hardware unless i absolutly have to

also, correct me if im wrong, i dont think it is the port mainly because its does work after i reconnect..
and its not like there is more then one way to connect a charger

i would mainly just like to know wether trying to reflash the stock rom may fix the problem.
and if so where can i find one that fits my country without all the mobile companies add-ons
which i can find at samobile website.
and also if anyone has a diffrent solution
Last edited by shahaf321; 2nd February 2014 at 04:51 PM.
2nd February 2014, 04:53 PM |#4  
twistedillutions's Avatar
Senior Member
Flag 209
Thanks Meter: 354
 
More
I ment usb port from device. I read that the port wears out in time. Im lucky mine hasnt. U have stock rom or custom? If u are i doubt its a software issues but with the 4.3 OTA u may never know wat issues may come up

Sent from my unknown using Tapatalk
2nd February 2014, 05:24 PM |#5  
shahaf321's Avatar
OP Member
Flag Hadera
Thanks Meter: 3
 
More
Quote:
Originally Posted by twistedillutions

I ment usb port from device. I read that the port wears out in time. Im lucky mine hasnt. U have stock rom or custom? If u are i doubt its a software issues but with the 4.3 OTA u may never know wat issues may come up

Sent from my unknown using Tapatalk

i did mean the device port, and as i have mentioned i am using stock rom. but to be honest i have no way of knowing wether the sellers were messing with the rom or not.

could u direct me to where i can find stock rom download that mobile companies does not touch?
i did find samobile but it has just the companies verisions such as orange and so..
because it appears like something i want to try anyway before starting to mess with the hardware
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes