5,815,179 Members 38,298 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Help with understanding logcat (dropping calls)

Tip us?
 
parkentosh
Old
(Last edited by parkentosh; 4th February 2014 at 09:38 AM.)
#1  
parkentosh's Avatar
Senior Member - OP
Thanks Meter 64
Posts: 209
Join Date: Feb 2012
Location: Tartu
Default [Q] Help with understanding logcat (dropping calls)

I have a strange issue with my HOX and i wonder if anyone can read something about that from my log. I've been having call dropping issue for a while now (seems to be on aosp only... sense roms work great). If i start a call and have data enabled I sometimes get an issue with signal dropping (No service). I never have that issue with data disabled. If i'm connected to a wifi network i don't have that issue. The issue is only there if I have data enabled and not connected to wifi network (either wifi off or out of range). I've been tring to understand what the problem is but I've had no luck (been searching for a solution for about a week... tried different settings... like "wcdma only" but the problem is still there)

The problem doesn't always arise but still pretty often... It happens often on some roms and not very often on other roms (I've only had this issue twice on cm11 but get it almost every other call on SlimKat). I've attached a logcat from SlimKat while outgoing call dropps signal. Hope any of you can shed a light on my issue. I looks like a hardware problem but i don't understand why it works on sense roms.

Edit: I first had this issue after I OTA'd to 4.18.401.2 (with new hboot 1.72). It's a shame HTC denies us s-off. Otherwise i would just go back to hboot 1.39 but i'm hoping i can somehow fix this because I really love AOSP roms and i really don't like Sense.

Edit2: This only happens on outgoing calls. Never on incoming calls.

Edit3:Took out the sim card. Polished it a bit. Put sim card back. Now in 10 test calls i never had signal dropping. I cut the sim card myself and now i guess it's time to go and get a proper microsim.

Edit4:Still had a signal drop on outgoing call.

Will report back after i get a new sim...
Attached Files
File Type: txt log with call dropping.txt - [Click for QR Code] (42.5 KB, 6 views)
----------------------------------------------
Devices:
Motorola Xoom 3G - CM11
HTC One X - CM11
Sony Xperia Z1 - Stock 4.4.4, rooted + custom kernel
 
parkentosh
Old
(Last edited by parkentosh; 4th February 2014 at 10:36 AM.)
#2  
parkentosh's Avatar
Senior Member - OP
Thanks Meter 64
Posts: 209
Join Date: Feb 2012
Location: Tartu
I tested the HOX with another sim card from another carrier. No problems whatsoever. I tried my sim card in an iPhone 4 and it worked without any issues. As soon as I put my sim card back in my hox and place a call I get "out of service" (with data active and wifi disabled). I just don't understand. Everything works great with data off or if I'm connected to a wifi. I really don't want to change my carrier (it's just so cheap )

BTW the sim card is not very old. Maybe a year max (although i did cut it to size myself but I've done that dozens of times for myself and my friends and have had no issues)

Anybody got any ideas? (haven't tested with different sim card from my carrier.. will test as soon i get a chance)
----------------------------------------------
Devices:
Motorola Xoom 3G - CM11
HTC One X - CM11
Sony Xperia Z1 - Stock 4.4.4, rooted + custom kernel
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes