Post Reply

Battery loss due to wake lock

3rd February 2014, 03:51 AM   |  #1  
spartan268's Avatar
OP Member
Thanks Meter: 6
 
65 posts
Join Date:Joined: Oct 2013
For the past few days my phone has been kept awake for over a hour per day. I used better battery stats to find out it is due to the "powermanagerservice.wakelocks".
Does anyone know how to stop this wake lock or at least control it so it isn't keeping my phone awake and draining battery.

Sent from my SGH-T999
3rd February 2014, 04:04 AM   |  #2  
spartan268's Avatar
OP Member
Thanks Meter: 6
 
65 posts
Join Date:Joined: Oct 2013
Sent from my SGH-T999
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1391400227707.jpg
Views:	47
Size:	66.3 KB
ID:	2555936   Click image for larger version

Name:	uploadfromtaptalk1391400240063.jpg
Views:	43
Size:	55.5 KB
ID:	2555937   Click image for larger version

Name:	uploadfromtaptalk1391400251531.jpg
Views:	42
Size:	55.0 KB
ID:	2555938   Click image for larger version

Name:	uploadfromtaptalk1391400259898.jpg
Views:	41
Size:	48.5 KB
ID:	2555939  
3rd February 2014, 05:40 PM   |  #3  
Perseus71's Avatar
XDA: ASSIST
Recognized Contributor
Atlantis
Thanks Meter: 3,971
 
6,535 posts
Join Date:Joined: Feb 2011
Donate to Me
More
Facebook is a hugh battery Drainer. Please remove it and turn off Location Service.

If you are rooted, please post Alarm and Partial Wakelock Screen.
4th February 2014, 02:40 AM   |  #4  
spartan268's Avatar
OP Member
Thanks Meter: 6
 
65 posts
Join Date:Joined: Oct 2013
Quote:
Originally Posted by Perseus71

Facebook is a hugh battery Drainer. Please remove it and turn off Location Service.

If you are rooted, please post Alarm and Partial Wakelock Screen.

Location is always off for me. Will try getting rid of Facebook. Also I already posted the alarm Wakelock Screen in above post.

Sent from my SGH-T999
4th February 2014, 02:41 AM   |  #5  
spartan268's Avatar
OP Member
Thanks Meter: 6
 
65 posts
Join Date:Joined: Oct 2013
Quote:
Originally Posted by Perseus71

Facebook is a hugh battery Drainer. Please remove it and turn off Location Service.

If you are rooted, please post Alarm Wakelock Screen.



Sent from my SGH-T999
4th February 2014, 12:36 PM   |  #6  
Perseus71's Avatar
XDA: ASSIST
Recognized Contributor
Atlantis
Thanks Meter: 3,971
 
6,535 posts
Join Date:Joined: Feb 2011
Donate to Me
More
I meant Alarms screen after turning off Location. If it was off already, then go to Settings >Wireless >Advanced. Set "Scanning Always Available during Sleep" to Never. Also uncheck "Always Allow Scanning".

FYI. Typically such wakelock issues are posted on the BBS Thread and not as Device Q&A.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in T-Mobile Galaxy S III Q&A, Help & Troubleshooting by ThreadRank