Tablet [Q] No recovery mode Sumvision Cyclone Voyager 7"

I'm really not sure where to ask this question but I need some help so thought I'd try posting on a forum (so please forgive noobishness)

I have a Sumvision Cyclone Voyager and it doesn't seem to boot into recovery, I've tried every combination I can think of:
Power+VolUp / Power+VolDown / Power+Both / VolDown+Reset / VolUp+Reset

I've even tried using Novo7 Tools and Arctools to try and boot to recovery from software but there just doesn't seem to be one, which is strange because I've rooted the device (using Arctools - Rockchip 3066 Root), I thought all root firmware came with custom recovery? Regardless there should be a stock android recovery anyway right??

Ps. I thought I should mention that my laptop recognizes the filesystems on the tablet and even shows "Cyclone" under Device Manager>Disk Drives but neither adb nor anything else (eg SausageScript) recognise a connected device (and Yes I did enable USB Debugging)

Would a factory reset help anything?

Please help! Any suggestions would be appreciated!

Thanks