Lightbulb [Q] Troubleshooting Samsung XCover 2 (GT-S7710): Cannot wake up phone

I'm having a sporadic problem with my xcover that i cannot diagnose. It happens very randomly, sometimes a few times a day, sometimes only 1 time in weeks. The phone functions normally and at some point i cannot wake the screen anymore, and then shortly after it freezes to the point that i need to hard restart it. So when this happens, none of the buttons do anything, so for example if i get a call the phone will ring for a bit with the screen black, me unable to do anything, then after a few seconds it freezes (if i try to call me it goes to voice mail) or if the alarm sounds i cannot stop it only if i pull out the battery, it just keeps playing at full volume with a black screen which is not responsive to the touch.

It's very frustrating that i cannot save any logs because i have to restart the phone in order to use it, and by then the problem is gone. I eliminated all the apps, so its not an app causing this. And its absolutely nothing specific that i'm doing to it. One time i just woke it up, unlocked it, looked at the clock, locked it, and when i went to wake it up again after 2-3 minutes, nothing, gone, completely unresponsive. Also, if i plug it in it makes the sound that its charging. Waiting does nothing, i tried to let it be for more the half an hour and its still the same. And it goes without saying battery is draining a lot faster when its in this 'dead' mode.

The rom with which it happens is the pre-rooted S7710XXAMB6_S7710OXEAMB3-20130713 stock rom.

Anybody has any clue?