Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Xperia Z1 + iHackers 4.3 + iHackers Kernel - 20MP Camera Hack...

OP coolio85

3rd February 2014, 01:22 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Feb 2014
Hi, after 12 hours of bricking and unbricking my phone and forgetting to save TA partition I have successfully got my phone working again with the custom ROM installed and semi working.

The main reason I wanted it was to get my camera working on 20MP with superior auto. However when I have taken photos on superior auto I am getting 8MP photos instead of 20MP. When installing the ROM I did choose th 20MP mod and have seen the mod is there via the security app but still struggle to get the camera to take 20MP on auto.

I would have liked to post this message in the correct post in the iHackers thread but the forum would rather I spam 10 posts before they allow me to post in there... Strange if you ask me as I do not have time to spam 10 posts, I would however stick around after this problem is resolved as I have just got into Android phones after finally leaving apple... :S

Does anyone else have the Z1 with this ROM and having the same issue?

PS. I forgot to save the TA partition like a NOOB! BUT every app is working fine except Wisepilot for Xperia, which installs but has asked me to pay for the features I am supposed to already have. I suspect this is due to the missing DRM files.

I know there is no way to get DRM back but what if I sent the phone to Sony and asked to pay to get them back, is that a possibility?

To recap:

1: How to get 20MP on superior auto...
2. Wisepilot for Xperia, does it work for free on this ROM?
3. Will Sony fix DRM for cash? If not, is there a way around this? Insurance?

Thanks.
3rd February 2014, 01:44 AM   |  #2  
eclyptos's Avatar
Senior Member
Planet Earth
Thanks Meter: 617
 
2,984 posts
Join Date:Joined: Jun 2008
Quote:
Originally Posted by coolio85

1: How to get 20MP on superior auto...

You have just 2 options to get 20mp in Superior Auto, 1 flash the VodafoneUK FTF 4.3 from HERE or use this Xposed HERE

Quote:
Originally Posted by coolio85

2. Wisepilot for Xperia, does it work for free on this ROM?

Probably not and is compatibility issue but maybe someone figure out how to let it work. Nothing what I am aware of.

Quote:
Originally Posted by coolio85

3. Will Sony fix DRM for cash? If not, is there a way around this? Insurance?

Ask them how this will cost you because nobody did this before and maybe is not worth to do it because the phone working properly anyway.
There is no way around to get back your DRM keys and no Warranty too now so anything you will have with your phone, you have to pay.
3rd February 2014, 11:13 AM   |  #3  
funky0308's Avatar
Recognized Themer
Flag Osijek
Thanks Meter: 5,537
 
6,782 posts
Join Date:Joined: Aug 2012
Donate to Me
More
If you installed xposed module in flashing process then you have it already and there's no need to install it again.

Go to settings/IHackers/Xposed framework and enable module.
Restart and that's it.

If it still won't work, go again in settings/iHackers/xposed framework and reinstall xposed framework again.

After every change (modules, xposed framework) you have to restart your device.

Sent from my C6903 using Tapatalk
4th February 2014, 08:51 PM   |  #4  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Feb 2014
Quote:
Originally Posted by coolio85

Hi, after 12 hours of bricking and unbricking my phone and forgetting to save TA partition I have successfully got my phone working again with the custom ROM installed and semi working.

The main reason I wanted it was to get my camera working on 20MP with superior auto. However when I have taken photos on superior auto I am getting 8MP photos instead of 20MP. When installing the ROM I did choose th 20MP mod and have seen the mod is there via the security app but still struggle to get the camera to take 20MP on auto.

I would have liked to post this message in the correct post in the iHackers thread but the forum would rather I spam 10 posts before they allow me to post in there... Strange if you ask me as I do not have time to spam 10 posts, I would however stick around after this problem is resolved as I have just got into Android phones after finally leaving apple... :S

Does anyone else have the Z1 with this ROM and having the same issue?

PS. I forgot to save the TA partition like a NOOB! BUT every app is working fine except Wisepilot for Xperia, which installs but has asked me to pay for the features I am supposed to already have. I suspect this is due to the missing DRM files.

I know there is no way to get DRM back but what if I sent the phone to Sony and asked to pay to get them back, is that a possibility?

To recap:

1: How to get 20MP on superior auto...
2. Wisepilot for Xperia, does it work for free on this ROM?
3. Will Sony fix DRM for cash? If not, is there a way around this? Insurance?

Thanks.

I have the same problem. I forgot to backup the TA partition and now suffering for losing those drm keys. The x reality engine is not functioning and i need that to watch movie. So sad.(still finding the solution how to gain back those drm.keys)

And then i did install ihackers rom to gain superior 20mp but its useless. 20mp is even worse when it comes to low light condition. so i disabled it. Not happy with this.
5th February 2014, 08:16 PM   |  #5  
Senior Member
Flag Wrocław PL/Nurnberg DE
Thanks Meter: 56
 
193 posts
Join Date:Joined: Jun 2012
More
The same here- dissapointed and regret Bootunlock- didnt actually now that would happen
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes