Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Bluetooth Low Energy Libraries for 4.2.2

OP backXslash

28th January 2014, 06:40 AM   |  #1  
OP Member
Thanks Meter: 48
 
30 posts
Join Date:Joined: Jun 2009
Does anyone have any ideas how one might go about fixing / adding / porting the BTLE libraries from 4.3 to 4.2.2?

Truthfully, I've tried damn near every rom available for the One X+, and RevolutionHD makes me the happiest. The only, and I do mean only, gripe I've got is that it's 4.2.2, and therefore does not support my FitBit Force.

All that is needed is working BTLE libraries, which can be third-party provided or activated under 4.2.2, I just don't know how. Any help would be greatly appreciated.
4th February 2014, 07:01 AM   |  #2  
OP Member
Thanks Meter: 48
 
30 posts
Join Date:Joined: Jun 2009
After some research, the HTC One supports BTLE on 4.2 & 4.1.2. Any one know if there's any chance we can port that over? Or are the chips different? The only real stumbling block here is that Android doesn't provide any BTLE support prior to 4.3, even though the hardware supports it. HTC wrote a BTLE stack for 4.1.2 & 4.2 for the One.

Any ideas?
4th February 2014, 06:19 PM   |  #3  
OP Member
Thanks Meter: 48
 
30 posts
Join Date:Joined: Jun 2009
I LIKE THAT I AM THE ONLY ONE IN THIS THREAD

6th February 2014, 03:05 PM   |  #4  
Senior Member
Flag KC
Thanks Meter: 10
 
118 posts
Join Date:Joined: Jan 2013
More
The 4.2.2 update includes BTLE.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes