Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,027 Members 49,291 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Sim Card Isn't Detected

Tip us?
 
Skimchee7
Old
(Last edited by Skimchee7; 5th February 2014 at 10:07 PM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Feb 2014
Default [Q] Sim Card Isn't Detected

Hello XDA,

I've been having this issue with my sim card since right after I flashed the latest CM 11 nightly (coming from a previous version). I just updated my bootloader and switched from TWRP to CWM earlier today. I had flashed the new nightly and after it asked for the system language, I received a pop-up window telling me to review my sim card instructions. This hasn't happened to me before, so I am extremely nervous and have been searching the web/forums for the entire afternoon with no such luck at finding a solution. I finally decided to make an account and post this thread with hopes that someone will be able to solve (or at least point me in the right direction to solving) my sim card error. Sorry if the answer is very obvious and I had missed it or something, I'm in a state of panic to be honest

Any help is greatly appreciated.

EDIT: I found a few links to a site for unlocking the network, but is this what I am looking for? I want to be 100% sure before I do anything risky. (I can't post the link because I am a new user :/ )
 
audit13
Old
#2  
audit13's Avatar
Senior Member
Thanks Meter 352
Posts: 2,177
Join Date: Jun 2012
Did you update to the 4.3 bootloader? Which phone do you have?
 
Skimchee7
Old
(Last edited by Skimchee7; 6th February 2014 at 01:42 AM.)
#3  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Feb 2014
Quote:
Originally Posted by audit13 View Post
Did you update to the 4.3 bootloader? Which phone do you have?
The bootloader I have installed is I747UCUEMJB. I assume it is sufficient because it was the latest one that I found available that worked with flashing the CM 11 nightly. My model is SAMSUNG-SGH-I747 by the way. The carrier is at&t. As some additional information, I've also tried restoring to the backup right before the rom flash that started my sim card errors and it didn't fix it.

EDIT: Also just found out that my IMEI number is "unknown". I tried entering *#197328640# into the dialer, but I didn't get the network menu (maybe it was taken out of CM 11?)
 
Skimchee7
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Feb 2014
Sorry for the double post. Just realized that it might be a 4.4/4.3 issue rather than CM 11 as for not having the dial pad menu. Are there any ways to generate a new IMEI based on the one found on my phone's label, and if so would there be a way to flash it onto my phone (did the connection menu in the dial pad get moved somewhere)? I wasn't aware that this scenario was even possible for the year or so that I've been flashing roms, so I'm coming to terms with having to buy a new phone
 
audit13
Old
#5  
audit13's Avatar
Senior Member
Thanks Meter 352
Posts: 2,177
Join Date: Jun 2012
Maybe this will help: http://forum.xda-developers.com/show....php?t=1804117
The Following User Says Thank You to audit13 For This Useful Post: [ Click to Expand ]
 
Skimchee7
Old
(Last edited by Skimchee7; 7th February 2014 at 05:38 AM.)
#6  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Feb 2014
Quote:
Originally Posted by audit13 View Post
Thank you, this is exactly what I need! My only problem is that I can't seem to figure out which COM port I need, I'm searching that thread to find an answer but no such luck yet.

EDIT: Sorry about that, just connected successfully, yet when I write it over I am getting an error that says the phone is not answering. I skipped the *#7284# step due to the 4.4 dialer not launching the menu, and instead I tried using the Diag method but it gets stuck halfway through and doesn't finish the command. Any ideas? :-/ sorry to be such a bother and thank you for your time

EDIT 2: I guess an option would be to downgrade to 4.3 somehow so then I can use the *#0808# code to access the menu. I'm not entirely sure if reverting from 4.4 to 4.3 is safe though
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

[OTA Captured] Verizon LG G Pad 8.3 Finally Gets Official KitKat Update

It’s been almost nine months since the LG G Pad … more

Enjoy Wallpaper Overload with PhotoPhase

We don’t usually feature live wallpapers on the XDA Portal unless they are somewhat innovative … more

Monitor What Your Phone’s Camera Sees with Android Wear

Having a smart device strapped to your wrist certainly has its merits. A … more

Mod Lets You Have Stereo Speakers on Your Sony Xperia Z1 (Sort Of)

The stereo speakers onthe Sony Xperia Z2areprobably a relatively large … more