Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

bugs with SHV-E210K build (i9300 variant)

OP kaijura

27th January 2014, 05:31 AM   |  #1  
kaijura's Avatar
OP Recognized Contributor
Thanks Meter: 1,817
 
1,302 posts
Join Date:Joined: Jan 2011
I have Omni booting and running on a E210K (It is a SGS3 Korean variant, only changes are LTE, 2GB and DMB antenna), but some major bugs need fixing. There not much if any device trees for these out there so I have just been modifying the i9300 and it works.

These are probably the major two issues I have for now:

1. without manually adding ro.zygote.disable_gl_preload=1 to the build prop, it won't boot. I noticed this line wasn't in the i9300 builds either, but it's definitely referenced in my builds:

Quote:

/android/omni/device/samsung/smdk4412-common/common.mk

# Set default USB interface
PRODUCT_DEFAULT_PROPERTY_OVERRIDES += \
persist.sys.usb.config=mtp \
ro.zygote.disable_gl_preload=true

2. Can't adjust the vibration in advanced settings, when I do I get the logcat message below, there is no (very light) feedback because it seems the value is set very low.
If I manually edit the values (by putting it up to 10+) I can get feedback, so it is working.
Code:
I/ActivityManager( 2466): Displayed org.omnirom.device/.DeviceSettings: +428ms
W/DeviceSettings_Utils_Read( 5375): file /sys/vibrator/pwm_val: 2
W/DeviceSettings_Utils( 5375): file /sys/vibrator/pwm_val not found: java.io.FileNotFoundException: /sys/vibrator/pwm_val: open failed: EACCES (Permission denied)
W/DeviceSettings_Haptic( 5375): key: vibrator_tuning
but I have no idea where/how to proceed.

My device tree is up over at:
https://github.com/kaijura/android_device_samsung_e210k

I am using the same omni sources for smdk4412-common and kernel.

Thanks in advance
Last edited by kaijura; 27th January 2014 at 08:10 AM.
27th January 2014, 06:12 PM   |  #2  
Senior Recognized Developer
Flag Owego, NY
Thanks Meter: 24,759
 
13,519 posts
Join Date:Joined: Aug 2007
Donate to Me
More
Quote:
Originally Posted by kaijura

I have Omni booting and running on a E210K (It is a SGS3 Korean variant, only changes are LTE, 2GB and DMB antenna), but some major bugs need fixing. There not much if any device trees for these out there so I have just been modifying the i9300 and it works.

These are probably the major two issues I have for now:

1. without manually adding ro.zygote.disable_gl_preload=1 to the build prop, it won't boot. I noticed this line wasn't in the i9300 builds either, but it's definitely referenced in my builds:


2. Can't adjust the vibration in advanced settings, when I do I get the logcat message below, there is no (very light) feedback because it seems the value is set very low.
If I manually edit the values (by putting it up to 10+) I can get feedback, so it is working.

Code:
I/ActivityManager( 2466): Displayed org.omnirom.device/.DeviceSettings: +428ms
W/DeviceSettings_Utils_Read( 5375): file /sys/vibrator/pwm_val: 2
W/DeviceSettings_Utils( 5375): file /sys/vibrator/pwm_val not found: java.io.FileNotFoundException: /sys/vibrator/pwm_val: open failed: EACCES (Permission denied)
W/DeviceSettings_Haptic( 5375): key: vibrator_tuning
but I have no idea where/how to proceed.

My device tree is up over at:
https://github.com/kaijura/android_device_samsung_e210k

I am using the same omni sources for smdk4412-common and kernel.

Thanks in advance

LTE screams "qcom modem" to me - perhaps look at the i9305 tree?
2nd February 2014, 08:47 PM   |  #3  
kaijura's Avatar
OP Recognized Contributor
Thanks Meter: 1,817
 
1,302 posts
Join Date:Joined: Jan 2011
Figured it out, for anyone searching for this problem - the issue has to do with the ramdisk portion of a (custom) kernel as it wasn't matching up omni's init setups.

Quote:
Originally Posted by Entropy512

LTE screams "qcom modem" to me - perhaps look at the i9305 tree?

Tried a i9305 build it was a little worse off (no mobile connection), haha. I'm thinking of submitting for an official build after I figure out the build for a working stock omni kernel.
Since this device gets few attention (maybe less than 50 in the sgs3 forum) is it possible that you guys could set the jenkins buildbot to build like every week or other week?
3rd February 2014, 06:46 PM   |  #4  
Senior Recognized Developer
Flag Owego, NY
Thanks Meter: 24,759
 
13,519 posts
Join Date:Joined: Aug 2007
Donate to Me
More
Quote:
Originally Posted by kaijura

Figured it out, for anyone searching for this problem - the issue has to do with the ramdisk portion of a (custom) kernel as it wasn't matching up omni's init setups.


Tried a i9305 build it was a little worse off (no mobile connection), haha. I'm thinking of submitting for an official build after I figure out the build for a working stock omni kernel.
Since this device gets few attention (maybe less than 50 in the sgs3 forum) is it possible that you guys could set the jenkins buildbot to build like every week or other week?

Hmm, that might be a possibility...
7th February 2014, 05:27 AM   |  #5  
Member
Thanks Meter: 22
 
67 posts
Join Date:Joined: Jul 2013
Quote:
Originally Posted by kaijura

I have Omni booting and running on a E210K (It is a SGS3 Korean variant, only changes are LTE, 2GB and DMB antenna), but some major bugs need fixing. There not much if any device trees for these out there so I have just been modifying the i9300 and it works.

These are probably the major two issues I have for now:

1. without manually adding ro.zygote.disable_gl_preload=1 to the build prop, it won't boot. I noticed this line wasn't in the i9300 builds either, but it's definitely referenced in my builds:


2. Can't adjust the vibration in advanced settings, when I do I get the logcat message below, there is no (very light) feedback because it seems the value is set very low.
If I manually edit the values (by putting it up to 10+) I can get feedback, so it is working.

Code:
I/ActivityManager( 2466): Displayed org.omnirom.device/.DeviceSettings: +428ms
W/DeviceSettings_Utils_Read( 5375): file /sys/vibrator/pwm_val: 2
W/DeviceSettings_Utils( 5375): file /sys/vibrator/pwm_val not found: java.io.FileNotFoundException: /sys/vibrator/pwm_val: open failed: EACCES (Permission denied)
W/DeviceSettings_Haptic( 5375): key: vibrator_tuning
but I have no idea where/how to proceed.

My device tree is up over at:
https://github.com/kaijura/android_device_samsung_e210k

I am using the same omni sources for smdk4412-common and kernel.

Thanks in advance

This says u r building a rom.Is it working fine?
thanks
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes