Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,733,372 Members 39,342 Now Online
XDA Developers Android and Mobile Development Forum

Google Search/Store not working wi-fi

Tip us?
 
Hocevar
Old
#1  
Hocevar's Avatar
Member - OP
Thanks Meter 7
Posts: 79
Join Date: Jan 2011
Location: Porto Alegre
Phone Google Search/Store not working wi-fi

For some reason I'm having trouble acessing google search/store while using my wi-fi connection, they just keep trying and eventually fails, the weird part is, this is only happening on our smartphones, google is working just fine on the PC(wired).

Anyone got any idea what this could be ?

PS: It also works just fine if on the 3G+
 
MrObvious
Old
#2  
MrObvious's Avatar
Senior Member
Thanks Meter 259
Posts: 1,863
Join Date: Mar 2008
Location: Wichita KS
Hmm could be DNS being weird. When you get to WiFi try using terminal emulator and ping Google and try on 3g.

Sent from my Nexus 5 using xda app-developers app
 
AliRavian
Old
#3  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Jan 2014
Cool change DNS address of your Router

I was having the same problem last month. I just changed my DNS servers entry to GOOGLE DNS servers address, and the issue was resolved.

Just go to your Router's configuration page, change your ISP (internet service provider) DNS entries to Google DNS addresses (8.8.8.8 and 8.8.4.4), and reboot your Router/Wifi hotspot. and voila, you will get the access.
 
Hocevar
Old
#4  
Hocevar's Avatar
Member - OP
Thanks Meter 7
Posts: 79
Join Date: Jan 2011
Location: Porto Alegre
Quote:
Originally Posted by AliRavian View Post
I was having the same problem last month. I just changed my DNS servers entry to GOOGLE DNS servers address, and the issue was resolved.

Just go to your Router's configuration page, change your ISP (internet service provider) DNS entries to Google DNS addresses (8.8.8.8 and 8.8.4.4), and reboot your Router/Wifi hotspot. and voila, you will get the access.
That was actually one of the first things I tried heh, unfortunately that didn't seem to help much.

Anyway, I apologize for not giving an update earlier but it seems that as of today the problem somehow vanished...dunno why, but hopefuly it was temporary, maybe my ISP being weird ? Who knows.

That being said, thanks for the help MrObvious and Ali I appreciate it
The Following User Says Thank You to Hocevar For This Useful Post: [ Click to Expand ]
 
Joshmmorrison
Old
#5  
Joshmmorrison's Avatar
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Jan 2014
I had similar problems. Only thing that cleared it up was a factory reset.

Sent from my SM-N900T using XDA Premium HD app
 
AliRavian
Old
#6  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Jan 2014
Yes, I think it was some temporary problem at your ISP end.
Tags
google, not working, search, store
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

LG G Watch Tool is a Toolkit all Owners Need

The LG G Watch is one of the first two devices hitting the market rocking the highly anticipated … more

Benchmark Your CPU Performance with Mini CPU Integer Script

When it comes to device testing, there are two types of people on XDA. The first … more

Rid Yourself of Charging Annoyances with No Wake on Charge Xposed Module

Almost every OEM has skinned and otherwise modifiedAndroid to suit … more