FORUMS

The Atlas of XDA

A few weeks ago, we asked you “How Does Your Location Affect Your Life As A Power User?”. In the days that … more

New Snapdragons: Some Context & Contrast

It hasn’t been a good year for Qualcomm so far. Every device featuring the Snapdragon 810 … more

Google To Launch Next Gen Android One On July 14

The first gen of Android One devices to be launched in India in September 2014 were … more

Droid Turbo Lollipop OTA, 2015 Moto G Leaked – XDA TV

Android Lollipop for the Droid Turbo has been released. That and much more … more

MMX A116i camera stops working after Samsung ROM Flash.

95 posts
Thanks Meter: 10
 
By bollyfan2005, Member on 24th January 2014, 08:40 AM
Post Reply Subscribe to Thread Email Thread
I flashed SamFlare V4 on my new MMX A116i. ROM worked great but rear camera stopped working. It just gives green and says camera failed. Front camera woks great. I tried various flashable zips provided in this thread but none of them worked. Also I got CameraFlashable zip from Sakethjoshi but that resolved the camera issue but stopped detecting SDCARD. So Camera library files would have not caused this problem but instead boot.img in the flashable zip could have problem. I think boot.img is causing this problem. I tried removing the camera files from the zip file and flashed it. I found that camera became OK but stop detecting SD card. So I suspect boot.img is causing this problem.

Then I thought I will manually replace all the Camera library files directly into device system folder but device doesn't allow it as it says files are in use. So not sure how to fix the camera problem. Till now I have flashed 4 ROMs (3 Samsung Rom and 1 Turbo HD Rom). I observed this camera problem only in Samsung Rom. Turbo HD RAM works fine.

Not sure how to fix the rear camera problem. Front camera works fine but only issue is w.r.t rear camara.
 
 
28th January 2014, 07:23 PM |#2  
blackbeard's Avatar
Recognized Contributor
Flag Somewhere around you
Thanks Meter: 447
 
Donate to Me
More
Quote:
Originally Posted by bollyfan2005

I flashed SamFlare V4 on my new MMX A116i. ROM worked great but rear camera stopped working. It just gives green and says camera failed. Front camera woks great. I tried various flashable zips provided in this thread but none of them worked. Also I got CameraFlashable zip from Sakethjoshi but that resolved the camera issue but stopped detecting SDCARD. So Camera library files would have not caused this problem but instead boot.img in the flashable zip could have problem. I think boot.img is causing this problem. I tried removing the camera files from the zip file and flashed it. I found that camera became OK but stop detecting SD card. So I suspect boot.img is causing this problem.

Then I thought I will manually replace all the Camera library files directly into device system folder but device doesn't allow it as it says files are in use. So not sure how to fix the camera problem. Till now I have flashed 4 ROMs (3 Samsung Rom and 1 Turbo HD Rom). I observed this camera problem only in Samsung Rom. Turbo HD RAM works fine.

Not sure how to fix the rear camera problem. Front camera works fine but only issue is w.r.t rear camara.

use the flashable zip from the LewaOS build. here's the link to that post
http://forum.xda-developers.com/show...92&postcount=3

sorry for the late reply..
5th February 2014, 07:33 AM |#4  
OP Member
Thanks Meter: 10
 
More
Thumbs up FM Radio problem
Quote:
Originally Posted by kevalthakkar

Try this....it's 1000000% working..

http://forum.xda-developers.com/show....php?t=2623163

Thanks. It worked. Now I have the issue with FM radio. Any idea on how to fix it ?
5th February 2014, 03:31 PM |#5  
Senior Member
Flag Aamchi Mumbai
Thanks Meter: 62
 
More
Thumbs up Try this for FM radio!!!
Quote:
Originally Posted by bollyfan2005

Thanks. It worked. Now I have the issue with FM radio. Any idea on how to fix it ?

Heres the link for FM radio Patch https://www.dropbox.com/s/5veccfbb7y...io%20patch.zip


The Following User Says Thank You to sanjeev7 For This Useful Post: [ View ]
7th February 2014, 05:18 AM |#6  
OP Member
Thanks Meter: 10
 
More
Thumbs up FM Radio problem
Quote:
Originally Posted by sanjeev7

Heres the link for FM radio Patch https://www.dropbox.com/s/5veccfbb7y...io%20patch.zip


Thanks for your help but FM radio problem continues to exists. FM radio hardware is not getting detected by Mobile Uncle tools. So looks like drivers are messed up.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes