FORUMS

[FTF] Sony Xperia Z Lollipop Release

Sony rolled out a Lollipop update for Xperia Z just yesterday. If you still haven’t gotten … more

Original Moto G Receives Lollipop, OTA Captured

The original Moto G was released almost two years ago. Motorola still continues to … more

Device Review: No.1 X1 Rugged Smartphone

We are almost at the end of Q2 for 2015, and we have seen most of the flagship phones for the … more

When a Friend or Family Member Asks for a Phone Recommendation, What Do You Tell Them?

The majority of us here at XDA would consider … more
Post Reply Subscribe to Thread Email Thread

MMX A116i camera stops working after Samsung ROM Flash.

24th January 2014, 08:40 AM |#1  
OP Member
Thanks Meter: 10
 
More
I flashed SamFlare V4 on my new MMX A116i. ROM worked great but rear camera stopped working. It just gives green and says camera failed. Front camera woks great. I tried various flashable zips provided in this thread but none of them worked. Also I got CameraFlashable zip from Sakethjoshi but that resolved the camera issue but stopped detecting SDCARD. So Camera library files would have not caused this problem but instead boot.img in the flashable zip could have problem. I think boot.img is causing this problem. I tried removing the camera files from the zip file and flashed it. I found that camera became OK but stop detecting SD card. So I suspect boot.img is causing this problem.

Then I thought I will manually replace all the Camera library files directly into device system folder but device doesn't allow it as it says files are in use. So not sure how to fix the camera problem. Till now I have flashed 4 ROMs (3 Samsung Rom and 1 Turbo HD Rom). I observed this camera problem only in Samsung Rom. Turbo HD RAM works fine.

Not sure how to fix the rear camera problem. Front camera works fine but only issue is w.r.t rear camara.
 
 
28th January 2014, 07:23 PM |#2  
blackbeard's Avatar
Recognized Contributor
Flag Somewhere around you
Thanks Meter: 445
 
Donate to Me
More
Quote:
Originally Posted by bollyfan2005

I flashed SamFlare V4 on my new MMX A116i. ROM worked great but rear camera stopped working. It just gives green and says camera failed. Front camera woks great. I tried various flashable zips provided in this thread but none of them worked. Also I got CameraFlashable zip from Sakethjoshi but that resolved the camera issue but stopped detecting SDCARD. So Camera library files would have not caused this problem but instead boot.img in the flashable zip could have problem. I think boot.img is causing this problem. I tried removing the camera files from the zip file and flashed it. I found that camera became OK but stop detecting SD card. So I suspect boot.img is causing this problem.

Then I thought I will manually replace all the Camera library files directly into device system folder but device doesn't allow it as it says files are in use. So not sure how to fix the camera problem. Till now I have flashed 4 ROMs (3 Samsung Rom and 1 Turbo HD Rom). I observed this camera problem only in Samsung Rom. Turbo HD RAM works fine.

Not sure how to fix the rear camera problem. Front camera works fine but only issue is w.r.t rear camara.

use the flashable zip from the LewaOS build. here's the link to that post
http://forum.xda-developers.com/show...92&postcount=3

sorry for the late reply..
5th February 2014, 07:33 AM |#4  
OP Member
Thanks Meter: 10
 
More
Thumbs up FM Radio problem
Quote:
Originally Posted by kevalthakkar

Try this....it's 1000000% working..

http://forum.xda-developers.com/show....php?t=2623163

Thanks. It worked. Now I have the issue with FM radio. Any idea on how to fix it ?
5th February 2014, 03:31 PM |#5  
Senior Member
Flag Aamchi Mumbai
Thanks Meter: 62
 
More
Thumbs up Try this for FM radio!!!
Quote:
Originally Posted by bollyfan2005

Thanks. It worked. Now I have the issue with FM radio. Any idea on how to fix it ?

Heres the link for FM radio Patch https://www.dropbox.com/s/5veccfbb7y...io%20patch.zip


The Following User Says Thank You to sanjeev7 For This Useful Post: [ View ]
7th February 2014, 05:18 AM |#6  
OP Member
Thanks Meter: 10
 
More
Thumbs up FM Radio problem
Quote:
Originally Posted by sanjeev7

Heres the link for FM radio Patch https://www.dropbox.com/s/5veccfbb7y...io%20patch.zip


Thanks for your help but FM radio problem continues to exists. FM radio hardware is not getting detected by Mobile Uncle tools. So looks like drivers are messed up.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in A116 Q&A, Help and Troubleshooting by ThreadRank