Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,733,098 Members 46,684 Now Online
XDA Developers Android and Mobile Development Forum

[Q] S4 4.1 Rom Required (Need BlueZ not BlueDroid)

Tip us?
 
Lights_On
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 28
Join Date: Feb 2008
Default [Q] S4 4.1 Rom Required (Need BlueZ not BlueDroid)

Hi All,

Hoping to pull on some knowledge if I can.

I have an S4 and need to find a JB 4.1 rom or earlier (ICS or similar). I have struggled to find one - does any one know where I can get a stock or other ROM. any is fine as long as it is 4.1 or earlier.

WHY?:
- My car Bluetooth system does not work with BlueDroid Bluetooth stack modification that was introduced in 4.2 and newer. 4.1 and before used BlueZ Bluetooth stack and worked great. Sadly BlueDroid is not backward compatible with some devices that worked on Bluedroid.

I have searched and searched with no joy on finding a 4.1 or earlier ROM. I have also tried suggested solutions on forums such as keep device Bluetooth visible and use app "Bluetooth auto connect".

I hope someone can share a link with me for a suitable ROM or perhaps show me a way of reverting from the new BlueDroid to the older BlueZ stack in a newer ROM.

if all else fails I guess I have to get rid of the phone and downgrade to an S3 that I know has widely available 4.1 ROM's.

Thank you in advance.
 
Me Gusta
Old
#2  
Me Gusta's Avatar
Senior Member
Thanks Meter 224
Posts: 821
Join Date: Mar 2013
No 4.1 on s4. Its only 4.2 and up

Me Gusta!
 
Lights_On
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 28
Join Date: Feb 2008
Yup that's what I thought thank you for confirming.

Any chance of any ROM with blues as well as bludroid in it?

Sent from my GT-I9300 using Tapatalk
Tags
bluedroid, bluez
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes