Post Reply

Serious EFS problem (No IMEI or IMEI SV)

OP jhb019

7th February 2014, 06:38 PM   |  #1  
OP Member
Flag London
Thanks Meter: 3
 
41 posts
Join Date:Joined: Jun 2012
More
Hi,

My model is the E988 from Taiwan.
Basically, I was using my phone this morning and it was fine but when I turned it on in the afternoon it couldn't get any network connection. About an hour later, I could get voice and text connection but no 3g. I then rebooted my phone and can't get any connection again. I looked in the settings and on the IMEI and IMEI SV it says unknown.

Fortunately, I had an EFS backup from a few months ago that I made with the Freegee app. However, I have since returned to stock and then only rooted it. I have not disable LGE security or installed a custom recovery. I tried to recover the EFS using the Freegee app but it didn't work. It said it was successful but the IMEi and IMEI SV still say unknown.

Does anyone know what my problem is? Do I need to have a custom recovery to restore my EFS using this app? I also have a baseband file that I made myself. Could it be fixed by installing this baseband file?

Also, I'm wondering why my phone randomly started working after an hour. Surely if the IMEI is corrupted it shouldn't work at all???
Thanks
7th February 2014, 07:12 PM   |  #2  
OP Member
Flag London
Thanks Meter: 3
 
41 posts
Join Date:Joined: Jun 2012
More
It also seems to be rebooting about every 30 mins
7th February 2014, 08:27 PM   |  #3  
Neroga's Avatar
Senior Member
Flag Saint Cloud, Florida
Thanks Meter: 556
 
1,281 posts
Join Date:Joined: Feb 2012
More
If you have the box the phone came in, the IMEI should be on there. Take it up to your service provider with the phone and they should be able to fix it. Had to do that for an old friend's GS3. Make sure you go back to stock, no root, no custom recovery before taking it in.

Sent from my LG-E980 using XDA Premium 4 mobile app
The Following User Says Thank You to Neroga For This Useful Post: [ View ]
7th February 2014, 09:16 PM   |  #4  
OP Member
Flag London
Thanks Meter: 3
 
41 posts
Join Date:Joined: Jun 2012
More
Quote:
Originally Posted by Neroga

If you have the box the phone came in, the IMEI should be on there. Take it up to your service provider with the phone and they should be able to fix it. Had to do that for an old friend's GS3. Make sure you go back to stock, no root, no custom recovery before taking it in.

Sent from my LG-E980 using XDA Premium 4 mobile app

Unfortunately, I purchased the phone on ebay. I live in the UK and the model I have is from Taiwan but thanks for the advice. I think I'm going to factory reset the phone and then return it to the seller as they said that it came with a 12 month sellers guarantee. Hopefully they will honour it.
9th February 2014, 10:07 PM   |  #5  
OP Member
Flag London
Thanks Meter: 3
 
41 posts
Join Date:Joined: Jun 2012
More
I have since factory reset the phone. I have also rooted it again and have tried recovering the EFS with freegee again but it still isn't working. I found another fix using adb:
Code:
su
dd if=/sdcard/m9kefs1.img of=/dev/block/platform/msm_sdcc.1/by-name/m9kefs1
dd if=/sdcard/m9kefs2.img of=/dev/block/platform/msm_sdcc.1/by-name/m9kefs2
dd if=/sdcard/m9kefs3.img of=/dev/block/platform/msm_sdcc.1/by-name/m9kefs3
However it didn't work. It said I didn't have permission and I didn't get asked for permission from superuser even though I am definitely rooted.

I then decided to have a look at /dev/block/platform/msm_sdcc.1/by-name/ to see what was actually there. What I found was quite weird. Firstly, all of the files are 0 bytes. Secondly, I noticed that when I did try the fix with freegee, the files did actually change and the dates on the files and the file sizes were correct. However, once I rebooted my phone, the file sizes had been reset to 0 bytes and the dates had been reset to 1970.

Please can someone explain why this is happening. if you can, I think it will fix my phone.

Thanks
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Optimus G Pro Q&A, Help & Troubleshooting by ThreadRank