5,597,762 Members 36,259 Now Online
XDA Developers Android and Mobile Development Forum

Error casting tabs

Tip us?
 
Houndx
Old
#1  
Member - OP
Thanks Meter 11
Posts: 52
Join Date: Feb 2009
Exclamation Error casting tabs

I've rooted, installed Eureka and everything has been peachy until tonight. Now I'm able to cast YouTube from my tablet and from the player in Chrome but if I try to cast a tab then the Chromecast shows "404 cannot find the requested version of the receiver app." Something something try again later, update the browser's CV extension. I've been able to cast tabs before tonight without issue. Searching was fruitless. Chrome and the cast extension are up to date. Rebooting the desktop and chromecast did not help either.

Any help in resolving this would be greatly appreciated.
 
texdroid
Old
#2  
texdroid's Avatar
Member
Thanks Meter 15
Posts: 44
Join Date: Jun 2011
Location: Htown
im having the same problem. Im able to use Fling but not Cast a tab
 
Kyonz
Old
#3  
Kyonz's Avatar
Senior Member
Thanks Meter 201
Posts: 160
Join Date: Jun 2010
Location: Auckland, New Zealand

 
DONATE TO ME
Sorry to hear this, I'll check my own now and do some troubleshooting!

Get back to you shortly with the results of my tests.

---------- Post added at 09:55 PM ---------- Previous post was at 09:24 PM ----------

Hi All,

Just did some checking and this appears to be a problem based on some changes from Google.

As of the latest updates to the Chrome plugin for chromecast it is no longer trusted against the older receiver (that we use for fling support). This is greatly unfortunate and we'll look to a solution as soon as possible.

In the mean time you can regain this functionality by changing your whitelist provider to google and restarting (however will lose fling and all the other nice goodies), we'll look at getting this fixed as soon as we can.

Kind regards,
Kyonz

---------- Post added at 10:13 PM ---------- Previous post was at 09:55 PM ----------

Hi All,

I managed to force the receiver version so it believes it's being sent from the old receiver and thus loads correctly.

This appears to be working (have tested via both tab casting and fling) and is now pushed out to the Team Eureka whitelist (you can reboot to force your device to update or it will receiver it within the next 24hours).

Sorry about this bug being experienced and thanks for bringing it to my attention via this thread. If you have any issues please let me know.

Kind regards,
Kyonz
The Following 2 Users Say Thank You to Kyonz For This Useful Post: [ Click to Expand ]
 
loceys
Old
#4  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Feb 2014
Default Error Casting

Quote:
Originally Posted by Kyonz View Post
Sorry to hear this, I'll check my own now and do some troubleshooting!

Get back to you shortly with the results of my tests.

---------- Post added at 09:55 PM ---------- Previous post was at 09:24 PM ----------

Hi All,

Just did some checking and this appears to be a problem based on some changes from Google.

As of the latest updates to the Chrome plugin for chromecast it is no longer trusted against the older receiver (that we use for fling support). This is greatly unfortunate and we'll look to a solution as soon as possible.

In the mean time you can regain this functionality by changing your whitelist provider to google and restarting (however will lose fling and all the other nice goodies), we'll look at getting this fixed as soon as we can.

Kind regards,
Kyonz

---------- Post added at 10:13 PM ---------- Previous post was at 09:55 PM ----------

Hi All,

I managed to force the receiver version so it believes it's being sent from the old receiver and thus loads correctly.

This appears to be working (have tested via both tab casting and fling) and is now pushed out to the Team Eureka whitelist (you can reboot to force your device to update or it will receiver it within the next 24hours).

Sorry about this bug being experienced and thanks for bringing it to my attention via this thread. If you have any issues please let me know.

Kind regards,
Kyonz

I rebooted the chromecast multiple times and it says that it updates through Eureka but when it's all done I keep getting the message "404 - Not Found cannot load the requested version of the CV receiver app. Please try again later. If the problem persists, try updating the CV extension in your browser".
 
Asphyx
Old
#5  
Senior Member
Thanks Meter 208
Posts: 1,417
Join Date: Dec 2007
Quote:
Originally Posted by Kyonz View Post
Just did some checking and this appears to be a problem based on some changes from Google.

As of the latest updates to the Chrome plugin for chromecast it is no longer trusted against the older receiver (that we use for fling support). This is greatly unfortunate and we'll look to a solution as soon as possible.
With the public release of the SDK the receiver went from V1 to V2.
Both should still work (because Plex is still using the old receiver if I'm not mistaken) but there may be something different in the way it gets called such as doing a check on the Whitelist for which receiver is required?
The Following User Says Thank You to Asphyx For This Useful Post: [ Click to Expand ]
 
r00t4rd3d
Old
#6  
Senior Member
Thanks Meter 165
Posts: 320
Join Date: Nov 2012
Location: Toilet
A few things to try:

Make sure you network is set to Home Network not private or public.

Make sure you disable any virtual network cards like what Virtual Box installs.

If on Windows 8 , right click on your wireless network and make sure Sharing is turned ON.

Windows 8.1 Change PC Settings, Network, pick your network, Find devices and content is set to ON.
The Following User Says Thank You to r00t4rd3d For This Useful Post: [ Click to Expand ]
 
loceys
Old
(Last edited by loceys; 10th February 2014 at 05:27 PM.) Reason: Question
#7  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Feb 2014
Quote:
Originally Posted by r00t4rd3d View Post
A few things to try:

Make sure you network is set to Home Network not private or public.

Make sure you disable any virtual network cards like what Virtual Box installs.

If on Windows 8 , right click on your wireless network and make sure Sharing is turned ON.

Windows 8.1 Change PC Settings, Network, pick your network, Find devices and content is set to ON.
Well, I tried casting today and without rhyme or reason it started working so, thanks for the suggestions.
Also, I wanted to know can I cast TWC via Chromecast browser because I get the message "contents on this page is not supported"
 
Asphyx
Old
#8  
Senior Member
Thanks Meter 208
Posts: 1,417
Join Date: Dec 2007
Quote:
Originally Posted by loceys View Post
Well, I tried casting today and without rhyme or reason it started working so, thanks for the suggestions.
Also, I wanted to know can I cast TWC via Chromecast browser because I get the message "contents on this page is not supported"
I suspect it was always a Google Backend problem...
How to implement V2 of the receiver while trying not to break those who still used V1 or had not updated to the new GServices yet.
They didn't succeed at first try I bet! LOL

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes