Unhappy Soft key issue !!!NOT THE HELICOPTER ISSUE!!!

I have an HTC ville S4 1.5 ghz. Boy has this phone been a problem. MY current issue is that whenever i flash a new rom and gapps, all capacative buttons fail to operate. The real problem though, is that the roms i have been flashing support the buttons and I am actually able to use them for a good hour or so after flashing. Then all of a sudden the buttons will stop working, come back for a bit, then stop again gradually getting a longer time before they work again and then eventually they just stop working completely

I have tried clearing cache, dalvik, and all that good stuff but my buttons never become restored. On my last rom Trickdroid they worked perfectly so i am not sure if this is software or hardware. I dont see anyone else with this problem but if you guys can help me out that would be great. And I am currently on CM 11 rom and have tried flashing beanstalk, dirty unicorns (all 4.4.2 roms) but have eventually come down with the same problem.

Thank you,