Default Linux on Android Ubuntu Gray screen error [SOLVED]

Hi.

This problem has been posted many times with no answer provided by anybody.

I'm not allowed to reply to the relevant threads as my post count is too low.

Here are the details of my tablet:

ainol Novo7 Venus running Android 4.2.2, Kernel 3.4.0
Latest version of Complete Linux Installer.

Currently writing this message using Ubuntu 10.10 on the tablet with USB keyboard & mouse using a 3.6 version of Firefox.

Works great, but Firefox is old, and I can't upgrade it on Ubuntu 10.10, so I thought I'd try a newer version of the OS.

I had reservations about how this would go as I've had major problems running anything newer on my desktop machine. I've run Ubuntu 10.10 on that for many years and was very happy with it. That's now running 12.10, using gnome-session-fallback. Unity sucks, and it simply won't work on my desktop.

Back to the Anal; sorry, ainol.

I've tried Archlinux, Debian, Fedora, and they all work to some extent, but the sotware is old. I've tried Ubuntu 12.04, and it appears to work on the surface, but Firefox crashes (Reported by others, but no cure).

I've also tried Ubuntu 13.04, 13.10 and 14.04 and al of them result in the blank gray screen as reported by many others.

I've managed to get around that and solve the gray screen problem on all of them.

The trick is to change the window manager. KDE is the default on all these, as obviously theyv'e discovered that unity doesn't work on tablets. However, KDE doesn't seem to work on a lot of them also judging by the number of people reporting this error.

The best window manager I have found to work is xfce4. It's not installed by default, and neither is my favourite terminal, or text editor.

Amazingly, none of these distributions even have a web browser installed.

If anyone needs help getting xfce4 installed, I'll be happy to provide instructions

In the meantime, good luck

Geoff