Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,771,526 Members 50,531 Now Online
XDA Developers Android and Mobile Development Forum

XDA forum behaving weirdly

Tip us?
 
Phukkitt
Old
#1  
Junior Member - OP
Thanks Meter 8
Posts: 29
Join Date: Jun 2013
Location: Stockholm
Default XDA forum behaving weirdly

Something is weird with XDA forums, because if I go to a page like for example this forum section then I immediately get redirected to the same adress but with ?nocache=1&z=129628017614096 at the end (numbers seem random every time).

I have no Idea why this happens, but since it happens even before the page is finished loading I get this message:
Quote:
Rate Limited

You have requested too many pages at once or there was another error. Please retry again, or check out the latest news over on the XDA News Portal.
Reloading the page fixes this, but it gets quite annoying to have to do this every time. Is this happening for anyone but me? Is there maybe a fix?
I am using FF 26 with AdBlock turned off, and I have allowed most of the site in NoScript except amazon-adsystem and skimresources
 
bitpushr
Old
#2  
bitpushr's Avatar
XDA:Administrator
Thanks Meter 1183
Posts: 989
Join Date: Mar 2007
Quote:
Originally Posted by Phukkitt View Post
Something is weird with XDA forums, because if I go to a page like for example this forum section then I immediately get redirected to the same adress but with ?nocache=1&z=129628017614096 at the end (numbers seem random every time).

I have no Idea why this happens, but since it happens even before the page is finished loading I get this message:


Reloading the page fixes this, but it gets quite annoying to have to do this every time. Is this happening for anyone but me? Is there maybe a fix?
I am using FF 26 with AdBlock turned off, and I have allowed most of the site in NoScript except amazon-adsystem and skimresources
Im surprised this is happened as we eliminated the reload code. You can try changing to the 2013-1024 theme to fix this. The "rate limited" error means that your browser was requesting the page a bunch of times.
Current Phone: Nexus 5 (Android L) | Oppo Find 5 (Omni)

Past Phones: Nexus 4, Samsung Galaxy SIII i9300, HTC One X, Galaxy Note, iPhone 4S, 4, 3G, 3 (Jailbroken), Motorola V360, HTC TyTN
Past Tablets/Devices: Arnova 10G2, Asus EEEPC 900a, IBM/Lenovo Thinkpads
 
Phukkitt
Old
#3  
Junior Member - OP
Thanks Meter 8
Posts: 29
Join Date: Jun 2013
Location: Stockholm
Quote:
Originally Posted by bitpushr View Post
Im surprised this is happened as we eliminated the reload code. You can try changing to the 2013-1024 theme to fix this. The "rate limited" error means that your browser was requesting the page a bunch of times.
Changing theme seems to have helped, thanks.

Yeah, since it reloads as soon as the page opens I understand the "Rate Limited"-message, it's just weird that it would reload in the first place. Sometimes it didn't reload right away, and then it was fine.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes