FORUMS

Which OEM Would You Like to Help?

Most manufacturers have moments of greatness and moments of decadence, and in the past few years … more

Root T-Mobile S6/Edge on 5.1.1 Without Tripping Knox

If you purchase phones from a carrier, you may be no stranger to the difficulties … more

IonVR Coming Soon, HTC M9 Dev Edition Gets Android 5.1 – XDA TV

The HTC M9 Developer Edition has received Android 5.1. That and … more

Android 5.1.1 Omni ROM For Motorola Xoom

Back in Feb 2011, the Motorola Xoom became the first device to be sold with Android 3.0 … more
Thread Deleted Subscribe to Thread Email Thread
Prev Previous Post   Next Post Next
Hi Guys,

A month or so ago my mom dropped her S3 into the toilet. I told her to put it in rice ASAP and I believe a day or so later she did (but perhaps later that night). When I turn the phone on, the blue SAMSUNG (or maybe it says Galaxy) logo comes on and shows up completely fine, but nothing else after that works.

The lights around the phone work as well, including when I hit the menu and back buttons on the bottom part of the phone. It vibrates properly when it should and I also get sound, no problem.

I've tried connecting the phone to my computer to salvage pictures and data but it doesn't recognize the device for some reason.

Is the phone completely toast or is there a way for me to fix it? It was in very good condition before this and had only been used for a year.

Thanks a lot for the help. Any advice is greatly appreciated.
Last edited by carter444; 14th February 2014 at 06:38 AM.
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes