5,606,409 Members 33,349 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Soft bricked

Tip us?
 
nerazull
Old
#1  
nerazull's Avatar
Junior Member - OP
Thanks Meter 1
Posts: 8
Join Date: Feb 2014
Unhappy [Q] Soft bricked

Hey good people, after an entire day of trying to tinker with my phone, I soft bricked it.

It started because I wanted a theme, that required CM. So I've browsed a lot of threads and tried some things, and a couple of restarts and factory resets later, it went downhill.

So, P760 20i, running stock 4.1.2, after the last factory reset, I rooted it using this tutorial. I did that in order to install this CWM, to further install CM 10.1, the one I needed. After I did all that and finally booted up in recovery mode, I wiped user data as per instructions in the last link, and when trying to install the ROM, an error felt the need to interfere with my plans. So that's how I ended up with a phone that, if I don't take 3 more pills now, I'm gonna give to the dog to chew on.

It powers on, passes the LG logo, after the screen goes white and it says Under Coding...and the only option is a button to Reset Phone (it's basically a restart phone). A pop-up immediatly appears, saying that com.android.phone has stopped. After I click OK on that it asks for my SIM PIN, it accepts it, and briefly shows a weird, low-res old-looking Android lock screen and then back to the blank screen with another pop-up, asking me about Mobile Networks. That's about all the interaction there is. Click Home button does nothing, clicking Back button just swipes the screen back on the screen, and Menu does nothing. Rebooting from that button is again useless.

That CWM is still there, I can access boot in recovery mode, but to no avail. I've wiped cache, wiped Dalvik Cache, rebooted and nothing. I've tried hard reset with vol down+home then power for 3 secs, release power but still hold down vol down+home until the friendly robot appears, but the result is the same, nothing happens.

During the day I went through more methods, I had a lot of trouble with fastboot which I couldn't get to work.

My question is, based on what I told you, can you instruct me in the right direction ? Also, now that this happened and if it's possible to fix it, could it be fixed with CM installed automatically, or will it be a stock reset and then again back to the drawing board ?

If you need any more details, I'll try to provide, I didn't do much after the last factory reset except for what you see here.
 
xdrc45
Old
(Last edited by xdrc45; 12th February 2014 at 03:35 AM.)
#2  
xdrc45's Avatar
Senior Member
Thanks Meter 254
Posts: 651
Join Date: May 2012
Location: Great White , Michigan
@nerazull Welcome to the forums.
I guess first things first.... With this device you cannot flash any custom roms without unlocking the bootloader first. You cannot flash any custom roms with this version of CWM recovery either and there is no work around for the bootloader such as loki.

When you installed CWM did you make a nandroid backup? I hope so.... this is always, always the first thing you do before making any changes to the system.
If you did then just boot into CWM and restore your nandroid backup and that should resolve your issue.

If you didn't perform a nandroid backup then you can try and flash one for your specific device (p760 jb) from cmahendra's nandroid thread here - http://forum.xda-developers.com/show....php?t=2136204

If the nandroid backup doesn't work then you'll have to follow cmahenda's unbrick guide by either using the offline or online flash here - http://forum.xda-developers.com/show....php?t=2085344
If you found my post Helpful Please click the Thank You Button!

Google Nexus 5 - Custom Rom - *Dirty Unicorns* - ElementalX - TWRP v2.7
LG Optimus L9 MS769 - *Kumakan 4.1.2* - Rooted - CWM - Locked BL
LG Motion 4G MS770 - Custom Rom - *CM 10*
HTC HD7 - WP - OS 7.8 - Custom Rom - *Deepshining* v8.1 Fully Unlocked
Samsung Admire - Custom Rom - *Open Android* v2.3.6
Huawei Ascend - M860 -Custom Rom - *CM 7.2*
Lenovo IdeaTab - A2109 - Custom Rom - *Paranoid/CM 10 Combo*
The Following User Says Thank You to xdrc45 For This Useful Post: [ Click to Expand ]
 
nerazull
Old
(Last edited by nerazull; 12th February 2014 at 04:22 AM.) Reason: being nice :)
#3  
nerazull's Avatar
Junior Member - OP
Thanks Meter 1
Posts: 8
Join Date: Feb 2014
@xdrc45 Well, I didn't perform any kind of backup, I usually don't (call me an optimist ...I'm actually sad now )

I woke up earlier and started reading the second topic you posted. I'm thinking about trying that and not the first one, since I see the first one MAY have some personal data, I would prefer a stock option.

The question is, does it matter that it was 20i before, must I find a 20i now, or can I take any other one ? Or any other one respecting country/provider ?
Also, the first one says that device must be rooted. Is it still rooted now, with the method I used and after the incident ?

I also tried a couple of ways to unlock the bootloader yesterday, best result I got was a phone restart but nothing different. I also couldn't find a way to tell if the bootloader was unlocked or not.

PS: Thanks for the welcome
 
xdrc45
Old
#4  
xdrc45's Avatar
Senior Member
Thanks Meter 254
Posts: 651
Join Date: May 2012
Location: Great White , Michigan
The nandroid backups are clean as in stock, rooted and all personal information is removed.
Personally i would try the nandroid backup firsr as that would be the fastest way to restore your device. Take a total of 5 min to try and yes the device should still be rooted.
My L9 had the same problem after I installed the L9 Recovery, I booted into CWM and made a backup and then when I rebooted to the OS I got the error Encrypting - Reset Phone. Booted back to CWM, restored my backup and everything was fine... turned out to be a problem with BusyBox.
For the kdz you only need one that is for your model# and that is the same version of OS that came installed on the device (ics or jb) for the offline flash.

When you successfully unlock the bootloader you will be taken to a verification screen to actually unlock it. Its a huge pain to achieve. What you can do one you restore the device and make a nandroid backup is
1. Install a launcher lile Apex or Nova
2. Install xposed framework
3. Inatall gravity box xposed module
4. Install xthemes xposed module
All the above allow you to make custom changes from the status bar to kk themes
If you found my post Helpful Please click the Thank You Button!

Google Nexus 5 - Custom Rom - *Dirty Unicorns* - ElementalX - TWRP v2.7
LG Optimus L9 MS769 - *Kumakan 4.1.2* - Rooted - CWM - Locked BL
LG Motion 4G MS770 - Custom Rom - *CM 10*
HTC HD7 - WP - OS 7.8 - Custom Rom - *Deepshining* v8.1 Fully Unlocked
Samsung Admire - Custom Rom - *Open Android* v2.3.6
Huawei Ascend - M860 -Custom Rom - *CM 7.2*
Lenovo IdeaTab - A2109 - Custom Rom - *Paranoid/CM 10 Combo*
The Following User Says Thank You to xdrc45 For This Useful Post: [ Click to Expand ]
 
nerazull
Old
(Last edited by nerazull; 12th February 2014 at 07:35 AM.) Reason: LE
#5  
nerazull's Avatar
Junior Member - OP
Thanks Meter 1
Posts: 8
Join Date: Feb 2014
Ok, I will take your advice and try with the backup first.
And btw, that's the same error I get, I said "Under Coding" because that's the word-by-word translation from my language, didn't think of "Encrypting" :P

In regards to the theme part, that's what I originally did. I found the same version of the theme I wanted as an XTHEME. I followed the instructions of the developer on the play store. I rooted using the same method I mentioned in OP, got the XPOSED framework, got XTHEMES Engine, got the theme, but it wasn't working as intended. The theme only changed a couple of icons and the battery icon, it was like 20% of what the screenshots on the play store were showing. It also had something resembling 256 colors in the drop-down menu.The comments and rating of the theme made me think that the problem was on my end.

I found the same theme that had another application method, and required one of these: CM10.1, CM10, CM9 ,AOKP and Paranoid Android, so I decided to try this one with CM10.1, maybe it wouldn't glitch.

Sadly, there were no reviews of the theme for my device, so I couldn't tell if it was a problem with this specific device+that theme.

I can't post outside links due to being new on the forums, but the themes I'm talking about can be found in the Play Store, search term "Deus Ex Android Blue", the first two should be Custom ROM one and XTHEME one. Maybe you have some insight.



PS: I see that you also have this device, albeit 769, and it's the only one with stock ROM on it. I'm not a very experienced user, should I still pursue bootload unlock+custom ROM ? Is it too much of a hassle ? I'd like to do it and not just for the theme (it's the main reason though), if I fix the current problem.

I found 2 methods that used adb/fastboot for unlocking, got Android SDK, adb worked fine but I couldn't do anything about fastboot. I also tried that method (I think "Lelus"), where you had to remove battery, plug in phone like that, "catch" the device and manually install it's driver, etc, but I didn't fully understand what to do there. I only did the first part. There was another link to a tutorial about this method, spanning 3-4 methods, and I saw it's pretty random, and my USB cable is also not very reliable, if I move it by just a bit it may interrupt the connection.



LE: I'm sorry I can't quote all the methods I tried yesterday so you can better respond to me, but I can't even remember all...at one time I had 20+ tabs on the subject, bookmarked a few, tried some, ran into scam websites claiming they had a good method, etc.

And one last thing (sorry for this wall of text reply ), you said this CWM I got can't install Custom ROMs, but can it flash the backup I need ?
 
xdrc45
Old
(Last edited by xdrc45; 12th February 2014 at 08:00 PM.)
#6  
xdrc45's Avatar
Senior Member
Thanks Meter 254
Posts: 651
Join Date: May 2012
Location: Great White , Michigan
@nerazull
See the thing is that using something like xposed framework modules, is that it literally makes changes to the framework and the phone just might not like one of those changes. Sometimes it won't apply all the way across the system and you may only end up with only 20% of the theme working because some of the themes were originally cm10+ themes ported to xposed and may have been developed for a specific device and isn't a 100% compatible or a bad download. Usually if it causes any problems you can just uninstall the module and reboot and everythings fine, if not that's where a backup comes in handy.

I haven't tried to unlocked mine yet, just because I really haven't had the time to spend a day flashing kdz and dealing with the inverted touch screen. I plan on it one of these days, I've already downloaded everything for the device to do it and even have fastboot already set up just in case. So yes you could say it is a pain to unlock the bootloader, but I'm pretty sure more people have been more successful at unlocking on the p760 than on other variants.

Fastboot is actually pretty easy to set up. Open device manager and open lelus fastboot script, minimize the fastboot script windows so you can see them both fully open on the screen. Turn off the device and remove the battery and keep it screen down on a flat surface, plug your USB cable into your PC not into the device yet - select #1 for fastboot - push any key to continue - quickly plug in the USB cable into the device and and put the battery back in - on device manager you will see "unknown device" pop up and right click on it quickly and select update driver - select manually install the driver - then navigate to where you have the fastboot diver folder and click on "usb _drv_windows" and install - once that's done repeat the process again to install the drivers again.

Yes that cwm version will flash the nandroid backup and mod zips.

One other thing you can try is apex launcher, that's what I'm using. With this you can change a lot of the launcher settings, change and edit the size and image for icons and folders to adding themes, I'm using kitkat HD multi launcher theme through apex and its really nice and clean.

I haven't tried it yet but you can also try themer beta
If you found my post Helpful Please click the Thank You Button!

Google Nexus 5 - Custom Rom - *Dirty Unicorns* - ElementalX - TWRP v2.7
LG Optimus L9 MS769 - *Kumakan 4.1.2* - Rooted - CWM - Locked BL
LG Motion 4G MS770 - Custom Rom - *CM 10*
HTC HD7 - WP - OS 7.8 - Custom Rom - *Deepshining* v8.1 Fully Unlocked
Samsung Admire - Custom Rom - *Open Android* v2.3.6
Huawei Ascend - M860 -Custom Rom - *CM 7.2*
Lenovo IdeaTab - A2109 - Custom Rom - *Paranoid/CM 10 Combo*
The Following User Says Thank You to xdrc45 For This Useful Post: [ Click to Expand ]
 
nerazull
Old
(Last edited by nerazull; 14th February 2014 at 11:36 AM.)
#7  
nerazull's Avatar
Junior Member - OP
Thanks Meter 1
Posts: 8
Join Date: Feb 2014
@xdrc45 Well, I managed to install a backup from your first suggested method and it worked fine. I also tried Nova Launcher for a bit, bit I just got my mind set up on that theme and it's not going away I've also managed to install the fastboot drivers using the Lelus method (don't know why, but your instructions here made much more sense to me then the other 2 I found )

I decided I still want to pursue unlocking the bootloader and installing CM 10.1, I really want to check it out.

Will this BL unlocking method work for me ? I couldn't find any mention of 20i in the thread. And if yes, can that CWM flash a custom ROM, unlike my current one ?

And of course, thanks for your help so far. Really appreciate it.
The Following User Says Thank You to nerazull For This Useful Post: [ Click to Expand ]
 
xdrc45
Old
(Last edited by xdrc45; 14th February 2014 at 07:17 PM.)
#8  
xdrc45's Avatar
Senior Member
Thanks Meter 254
Posts: 651
Join Date: May 2012
Location: Great White , Michigan
@nerazull Hey you're welcome.... glad I could be of help.
I don't think v20i is unlockable, you could try and issue the unlock command but I'm pretty sure you will have to flash to a European open kdz like v20b and then follow the tutorial and yes that CWM will work.

You could also use markolino631 Tool box to try and unlock the bootloader. It issues the unlock command and can flash CWM for you easily ... There's a CWM for cm10 and the new version has one for cm11.
http://forum.xda-developers.com/show....php?t=2190326

I'm surprised you're going for cm10.1 instead of cm11
If you found my post Helpful Please click the Thank You Button!

Google Nexus 5 - Custom Rom - *Dirty Unicorns* - ElementalX - TWRP v2.7
LG Optimus L9 MS769 - *Kumakan 4.1.2* - Rooted - CWM - Locked BL
LG Motion 4G MS770 - Custom Rom - *CM 10*
HTC HD7 - WP - OS 7.8 - Custom Rom - *Deepshining* v8.1 Fully Unlocked
Samsung Admire - Custom Rom - *Open Android* v2.3.6
Huawei Ascend - M860 -Custom Rom - *CM 7.2*
Lenovo IdeaTab - A2109 - Custom Rom - *Paranoid/CM 10 Combo*
The Following User Says Thank You to xdrc45 For This Useful Post: [ Click to Expand ]
 
nerazull
Old
(Last edited by nerazull; 15th February 2014 at 03:13 PM.)
#9  
nerazull's Avatar
Junior Member - OP
Thanks Meter 1
Posts: 8
Join Date: Feb 2014
@xdrc45 Well, I did try to unlock 20i with the method I mentioned but it didn't work, I decided to flash v20b europe open. I flashed v20b Europe Open (just got the kdz from there, didn't follow those steps, didn't go back to ICS) using offline method (had to hard reset after because I was stuck in a bootloop, it worked fine after). I've got the fastboot drivers installed like I said before, I've checked and they're installed correctly. I've also installed/uninstalled the LG drivers twice, once offline to make sure Windows doesn't search for updates, and I still can't unlock bootloader. I've tried both unlocking methods aforementioned and the phone just reboots normally.

I've made these screenshots of what my Device Manager looks like, just for the sake of being thorough.

In phone, Software Version now says P76020b. Could the problem be here, shouldn't it say EUR-something ?

And I'm going for CM 10.1 for that theme, if it works and I like it I'll make a backup and get CM11 and see if they're compatible or not and move on from there That is, if I can get this bl unlocked.


LE: In the [2in1GUIDE] there's this post that mentions BusyBox. My device is not rooted after the kdz flash and obviously I don't have BusyBox. But that wouldn't make sense since it's not a pre-requisite in the tutorial and the tutorial is also meant to root.
There's also this...and this confuses me even further + other random occurrences.

Is it safe to assume that I should start experimenting ?
Attached Thumbnails
Click image for larger version

Name:	drivers1.png
Views:	15
Size:	20.5 KB
ID:	2580140   Click image for larger version

Name:	drivers2.png
Views:	16
Size:	21.6 KB
ID:	2580141   Click image for larger version

Name:	drivers3.png
Views:	15
Size:	12.5 KB
ID:	2580142   Click image for larger version

Name:	drivers4.png
Views:	12
Size:	2.0 KB
ID:	2580143  
 
xdrc45
Old
#10  
xdrc45's Avatar
Senior Member
Thanks Meter 254
Posts: 651
Join Date: May 2012
Location: Great White , Michigan
Yeah these L9's can be a pain in the @ss, but the nice thing is you can recover it from almost anything.
Just keep trying and don't give up on it. I've seen where some people have tried multiple times to unlock, like 20 times without success and then they try again and boom, unlock success. Make sure you have and are using the phones service and wifi. Make some calls and watch some videos or a movie on it.... You need to receive the token, this is the whole reason for waiting an hour before issuing the unlock command, but it may take longer than an hour or two to receive it, like some waited 10 hours and then the unlock worked.
Unfortunately there is no one set way to unlock and everyone has had different experiences and tried different techniques to get it to work. All you can do is, as you said "Experiment" and exhaust all options.
If you found my post Helpful Please click the Thank You Button!

Google Nexus 5 - Custom Rom - *Dirty Unicorns* - ElementalX - TWRP v2.7
LG Optimus L9 MS769 - *Kumakan 4.1.2* - Rooted - CWM - Locked BL
LG Motion 4G MS770 - Custom Rom - *CM 10*
HTC HD7 - WP - OS 7.8 - Custom Rom - *Deepshining* v8.1 Fully Unlocked
Samsung Admire - Custom Rom - *Open Android* v2.3.6
Huawei Ascend - M860 -Custom Rom - *CM 7.2*
Lenovo IdeaTab - A2109 - Custom Rom - *Paranoid/CM 10 Combo*

The Following User Says Thank You to xdrc45 For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes